Search found 68 matches

by Gordon_Hardman
Fri Aug 16, 2019 3:33 pm
Forum: Pyboard D-series
Topic: Programming a D-series in Win64
Replies: 7
Views: 306

Re: Programming a D-series in Win64

I can run Zadig, but I am not at all sure how to use it as described! After much Googling, I can't seem to find a step-by-step guide. Can anyone point me to some simple instructions?
by Gordon_Hardman
Thu Aug 01, 2019 4:02 pm
Forum: Pyboard D-series
Topic: Programming a D-series in Win64
Replies: 7
Views: 306

Re: Programming a D-series in Win64

Thanks- I have downloaded Zadig. Since I have never used it, I am being cautious and need to figure out how to use it!
by Gordon_Hardman
Wed Jul 31, 2019 2:53 am
Forum: Pyboard D-series
Topic: Programming a D-series in Win64
Replies: 7
Views: 306

Programming a D-series in Win64

I have used dfuse-demo for many years with the PYB 1.0, 1.1 and a bunch of custom boards, all using STM32F4xx. No problem ever. Must have upgraded hundreds of times. I now have a D-series (pink SF3W) and have downloaded the latest release PYBD_SF3_W4F2.dfu. When I put it in DFU modes (using usr and ...
by Gordon_Hardman
Mon Apr 01, 2019 5:27 pm
Forum: Other Boards
Topic: Need help with Makefile for ATMEL SAMV7
Replies: 9
Views: 1747

Re: Need help with Makefile for ATMEL SAMV7

I know this is an old post, but I was curious if you were ever able to successfully do this?
by Gordon_Hardman
Thu Oct 04, 2018 10:51 pm
Forum: Other Boards
Topic: [STM32F405 custom board] USB does not show up
Replies: 3
Views: 382

Re: [STM32F405 custom board] USB does not show up

I found the problem. Even though I am not using the 5V that comes in with the USB, it must still be connected to PA9-VBUS. This is so the chip can tell when the USB is plugged in, and when it is removed.

Duh! Slap forehead.

Sorry for the bandwidth, but maybe this will help someone!
by Gordon_Hardman
Thu Oct 04, 2018 9:15 pm
Forum: Other Boards
Topic: [STM32F405 custom board] USB does not show up
Replies: 3
Views: 382

[STM32F405 custom board] USB does not show up

I have a custom designed board using exactly the same chip as in the PyBoard, ARM STM32F405RGT6. My hope is that it will run the Pyboard code with no modifications. But there is a problem with the USB not showing up. Here are the symptoms: 1. The device shows up in DFuseDemo, and I can upload the la...
by Gordon_Hardman
Wed Aug 29, 2018 4:24 pm
Forum: MicroPython pyboard
Topic: SPI initialization not working
Replies: 2
Views: 362

SPI initialization not working

I am using a PyBoard 1.1, with the latest 1.9.4 firmware: MicroPython v1.9.4 on 2018-05-11; PYBv1.1 with STM32F405RG I try to create an SPI object, but it does not seem to take my initialization. Here is from REPL: >>> spi=SPI(1, SPI.MASTER, baudrate=600000, polarity=1, phase=0, bits=16, firstbit=SP...
by Gordon_Hardman
Mon Aug 13, 2018 6:11 pm
Forum: MicroPython pyboard
Topic: pyboard doesn't show up as USB flash device on Windows 10 machine
Replies: 14
Views: 4875

Re: pyboard doesn't show up as USB flash device on Windows 10 machine

On reflection, the problem must be with the USB peripheral on the ST chip. This is because the USB device does not show up in DFuse or as a composite memory/com USB device. I have now verified this on 5 PCs, 4 running Windows 10, and one Windows 7. I remember reading somewhere that the Pyboard could...
by Gordon_Hardman
Thu Aug 09, 2018 5:27 pm
Forum: MicroPython pyboard
Topic: pyboard doesn't show up as USB flash device on Windows 10 machine
Replies: 14
Views: 4875

Re: pyboard doesn't show up as USB flash device on Windows 10 machine

It is definitely a Windows issue, but there is an interesting Pyboard tie-in. Now all of my Windows PCs will not recognize the V1.1 Pyboards. Except that the V1.0 Pyboard is okay on two of the machines- but has the double COM port issue on PC #2. Also, since moving the V1.1 boards around my digital ...
by Gordon_Hardman
Wed Aug 08, 2018 8:45 pm
Forum: MicroPython pyboard
Topic: pyboard doesn't show up as USB flash device on Windows 10 machine
Replies: 14
Views: 4875

Re: pyboard doesn't show up as USB flash device on Windows 10 machine

I have a related problem which shares some of these symptoms. I have three Windows 10, 64 bit pro machines. I recently bought two Pyboard 1.1 boards via Digikey. PC #1: Nothing when I plug either of these boards in. This machine works great with a Pyboard 1.0. DFUSE does not see the Pyboards either....