Search found 7 matches

by Ketsa
Sun Nov 05, 2017 10:13 pm
Forum: ESP32 boards
Topic: MicroPython on ESP32 with SPIRAM support
Replies: 457
Views: 120636

Re: MicroPython on ESP32 with SPIRAM support

I found the ESP32-WROVER module pretty cheap on electrodragon, but ...
Does anyone know where to get a breakout board for it ?
by Ketsa
Sat Jan 21, 2017 8:20 pm
Forum: Drivers for External Components
Topic: Unable to use SPI display. Help please.
Replies: 27
Views: 11100

Re: Unable to use SPI display. Help please.

It works ! Thanks !

Somewhat :-p I have a problem displaying text past ~x:100, the text gets strangely overlaid by bg color.
by Ketsa
Tue Jan 17, 2017 8:59 pm
Forum: ESP32 boards
Topic: Esp32 port
Replies: 35
Views: 16084

Re: Esp32 port

EasyRider wrote:+1. Hopefully more reliable than 8266.

Have given up on ESP8266 as unreliable with too many issues for my needs.
More info on the problems you encountered ?
by Ketsa
Tue Jan 17, 2017 7:27 pm
Forum: Drivers for External Components
Topic: Unable to use SPI display. Help please.
Replies: 27
Views: 11100

Re: Unable to use SPI display. Help please.

I can confirm the new class works on my black pcb screen ! Thanks a lot !

Now, how can I display text on this thing ?
by Ketsa
Mon Jan 16, 2017 7:28 pm
Forum: Drivers for External Components
Topic: Unable to use SPI display. Help please.
Replies: 27
Views: 11100

Re: Unable to use SPI display. Help please.

I captured the screen init and few commands, channels look at least active.
Here is the Sigrok file, maybe its useful to you ?

https://dl.dropboxusercontent.com/u/319 ... 5-Black.sr

I'm not really a programmer, I doubt I can copy that init sequence, will have a look tomorrow.
by Ketsa
Mon Jan 16, 2017 8:35 am
Forum: Drivers for External Components
Topic: Unable to use SPI display. Help please.
Replies: 27
Views: 11100

Re: Unable to use SPI display. Help please.

Mine is black, I think they talk about the PCB color, (the protection film tab is green). I got it from Aliexpress, it looks exactly like this one : https://www.aliexpress.com/item/J34-F85-Free-Shipping-1-44-Serial-LCD-Display-128-128-SPI-TFT-Color-Screen-With/32599757275.html Yes, I used the adafru...
by Ketsa
Sun Jan 15, 2017 2:58 pm
Forum: Drivers for External Components
Topic: Unable to use SPI display. Help please.
Replies: 27
Views: 11100

Re: Unable to use SPI display. Help please.

[quote="deshipu"] Did you get it to work with any other board, like, say, Arduino?[/quote] I have the same problem as OP I think. Nothing except a blank (white) screen. Checked connections to be exactly as your recent post, used your code to test. No errors, but the screen stays blank... tested with...