Search found 16 matches

by ST58
Tue Nov 14, 2017 1:15 pm
Forum: Other Boards
Topic: Nucleo429 no usb
Replies: 2
Views: 725

Re: Nucleo429 no usb

Regardless of the unhelpful response, this is about developing micropython! The reason the Nucleo429 port is 'broken' i.e no usb functionality, is due to a mistake in the board mpconfigboard.h file The settings for the stm clock pll's are incorrect and the USB clock is being set at the wrong frequen...
by ST58
Tue Nov 14, 2017 8:04 am
Forum: General Discussion and Questions
Topic: Timer Encoder mode
Replies: 2
Views: 778

Re: Timer Encoder mode

Thank you Peter - initialising the gpio's correctly fixed the problem
by ST58
Mon Nov 13, 2017 5:43 pm
Forum: General Discussion and Questions
Topic: Timer Encoder mode
Replies: 2
Views: 778

Timer Encoder mode

I have a quadrature encoder connected on a PyBoard to X1 and X2. I am trying to set up Timer2 in encoder mode to use with the encoder. I am inputting with REPL - I have tried.. timer = pyb.Timer(2) pin1 = pyb.Pin(pyb.Pin.board.X1,mode=pyb.Pin.AF_PP,af=pyb.Pin.AF1_TIM2) pin2 = pyb.Pin(pyb.Pin.board.X...
by ST58
Sat Nov 11, 2017 7:36 am
Forum: Development of MicroPython
Topic: Setup build using Bash under Win10
Replies: 2
Views: 1308

Re: Setup build using Bash under Win10

Sorry, but being able to set up the build environment so you can build is actually quite relevant to micro python development so this topic is in the right place
by ST58
Fri Nov 10, 2017 4:12 pm
Forum: Other Boards
Topic: Nucleo429 no usb
Replies: 2
Views: 725

Nucleo429 no usb

Nucleo429 port builds, but the usb functionality is not working. When plugged in brings up 'USB device not recognized ' Building the Nucleo 767 port does work as expected, so I know my build/flashing etc is all working On the Nucleou429, USB not working, so no flash drive etc., but you can connect R...
by ST58
Fri Nov 10, 2017 3:18 pm
Forum: Other Boards
Topic: Setup Bash under Win 10 to build stm32 boards
Replies: 3
Views: 1245

Re: Setup Bash under Win 10 to build stm32 boards

Don't know how the post mysteriously moved to 'other boards'. It was under development of micropython! Anyway the problem of getting python setup that works with the build files has been solved. See the new thread in 'development of micropython' which explains how to install the tools and config sys...
by ST58
Fri Nov 10, 2017 11:09 am
Forum: Development of MicroPython
Topic: Setup build using Bash under Win10
Replies: 2
Views: 1308

Setup build using Bash under Win10

This is how to get the build tools working in Win10 using Bash Under Win 10 Why.... I tried a VM using hypervisor - whereas this worked in that I could build, you cannot access usb from the vm and getting the compiled hex/dfu files back to windows was awkward - plus I found the hypervisor vm had a h...
by ST58
Thu Nov 09, 2017 4:39 pm
Forum: Other Boards
Topic: Setup Bash under Win 10 to build stm32 boards
Replies: 3
Views: 1245

Re: Setup Bash under Win 10 to build stm32 boards

Its not quite right yet!!!! I did the tests on my test pc, which is using win10 build 1607 - when you install bash under win10 it downloads and install Ubuntu 14.04 - and the above package install sequence works just fine. However, when I went to repeat the installation on my production machine - wh...
by ST58
Thu Nov 09, 2017 9:40 am
Forum: Other Boards
Topic: Setup Bash under Win 10 to build stm32 boards
Replies: 3
Views: 1245

Setup Bash under Win 10 to build stm32 boards

This is a setup for build the stm32 boards under windows using Bash for Win 10 I find this more convenient than using a Linux vm under windows as it is easier to get at the final hex/dfu files and then use STMLINK or the STM DFU app under windows to flash the boards Install Bash under Win 10 - I fol...
by ST58
Thu Nov 09, 2017 9:19 am
Forum: Other Boards
Topic: Build Nucleo767 build option error
Replies: 2
Views: 777

Re: Build Nucleo767 build option error

Yes, I suspected the problem was an old version of gcc which did not support M7. Not really being a Linux person, what I didn't know was how to correct the problem and get the latest version of gcc installed, where to get the package from etc. I have loaded Ubuntu as a vm using hypervisor and that a...