Search found 24 matches

by rpi_nerd
Fri Sep 11, 2020 2:30 pm
Forum: ESP8266 boards
Topic: Having trouble working with 1-wire device(DS1990A)
Replies: 0
Views: 895

Having trouble working with 1-wire device(DS1990A)

I've been playing around this morning with 1-wire I-button device (DS1990A). I've been able to detect it with scan() but I haven't managed to read its serial number. I just getting all ones. I'm probably doing something incredibly stupid. I've tried various combos such as inserting ow.reset() with a...
by rpi_nerd
Mon Jan 06, 2020 4:47 pm
Forum: ESP8266 boards
Topic: Strange REPL issue
Replies: 2
Views: 646

Re: Strange REPL issue

Today I removed the rx/tx series resistors and hooked up another USB to serial adapter. Same symptoms so it looked like the ESP8266 module was at fault, but I noticed something. After I hit the reset button on the module and tried to type on the console, the activity light on my USB to serial adapte...
by rpi_nerd
Sun Jan 05, 2020 5:16 pm
Forum: ESP8266 boards
Topic: Strange REPL issue
Replies: 2
Views: 646

Re: Strange REPL issue

I dug into the issue further. After I hit the reset button there's no activity between the TX pin of the CH340/RX pin of the ESP8266. So it's either the CH340 chip that's the issue or if the ESP8266 is pulling the line down. My next step is to remove the 470 ohm resistor in series and isolate the ES...
by rpi_nerd
Tue Dec 17, 2019 6:08 pm
Forum: ESP8266 boards
Topic: Strange REPL issue
Replies: 2
Views: 646

Strange REPL issue

I got another WeMos D1 board yesterday. I flashed the latest version of MicroPython today. I was able to get to the REPL prompt, but I couldn't send any characters, just receive. I found that by plugging it in but not hitting reset I can send characters just fine. I flashed an older version of the f...
by rpi_nerd
Fri May 31, 2019 12:21 pm
Forum: ESP8266 boards
Topic: Curious if anyone else has run across this failure mode(responsive but wifi failed)
Replies: 2
Views: 662

Re: Curious if anyone else has run across this failure mode(responsive but wifi failed)

I did try network scan(using wlan.scan()) and it failed. It worked fine in the past.
by rpi_nerd
Thu May 30, 2019 10:49 pm
Forum: ESP8266 boards
Topic: Curious if anyone else has run across this failure mode(responsive but wifi failed)
Replies: 2
Views: 662

Curious if anyone else has run across this failure mode(responsive but wifi failed)

Today I grabbed an ESP-12E I had lying around and flashed it the MicroPython firmware. Everything appeared to be going well until it came to setup wifi. No matter what, it simply wouldn't connect to my router. I tried two different firmware versions, same result. I decided to try it under the Arduin...
by rpi_nerd
Thu Dec 07, 2017 9:40 pm
Forum: ESP8266 boards
Topic: [SOLVED] unable to get REPL prompt
Replies: 17
Views: 9620

Re: [SOLVED] unable to get REPL prompt

Glad that my thread was able to help you bogd :)
by rpi_nerd
Thu Oct 12, 2017 6:02 pm
Forum: General Discussion and Questions
Topic: [SOLVED]onewire library converting ow.scan() output to an integer
Replies: 2
Views: 1365

Re: onewire library converting ow.scan() output to an integer

Got it now, the links you posted helped. The problem surrounded around the variable that I stored the result of ow.scan() becoming a list object that resulted in errors when I tried to convert it, so I needed to copy the array to another variable. Once that was done, I was able to use int.from_bytes...
by rpi_nerd
Thu Oct 12, 2017 2:23 pm
Forum: General Discussion and Questions
Topic: [SOLVED]onewire library converting ow.scan() output to an integer
Replies: 2
Views: 1365

[SOLVED]onewire library converting ow.scan() output to an integer

I've been playing around with the onewire library to read the keycode on my iButton (DS1995L-F5+) When I get the keycode from ow.scan() it gives me the output:

Code: Select all

bytearray(b'\n$\xb9\x1a\x00\x00\x00~') 
How to I convert the output to an integer?
by rpi_nerd
Wed Sep 13, 2017 5:33 pm
Forum: General Discussion and Questions
Topic: After upgrade firmware disappeared main.py
Replies: 3
Views: 1543

Re: After upgrade firmware disappeared main.py

When you do a firmware update, I believe any existing files that you had on the device (such as main.py) get erased. I know that at least for the esp8266 firmware there is no main.py by default.