Search found 17 matches

by SUBBU3881
Mon Apr 09, 2018 11:45 am
Forum: General Discussion and Questions
Topic: Cross compiling to arm-linux
Replies: 7
Views: 5481

Re: Cross compiling to arm-linux

Hello, Nice discussion. I am also trying to port micropython on to Beagle-Bone Black Linux board. I am facing <b> ffi.h not found<b> issue. This is looking for ffi.h typically in /usr/include someplace. You either need to install libffi-dev or disable ffi by setting building with make MICROPY_PY_FFI...
by SUBBU3881
Fri Feb 16, 2018 5:28 am
Forum: General Discussion and Questions
Topic: Porting into TriCore Environment
Replies: 28
Views: 6486

Re: Porting into TriCore Environment

The HighTec IDE don't support Python Scripts Building, So I ran them seperately in Linux PC and added those to my project settings.
can you please give examples to run those scripts.?
by SUBBU3881
Thu Feb 15, 2018 12:10 pm
Forum: General Discussion and Questions
Topic: Porting into TriCore Environment
Replies: 28
Views: 6486

Re: Porting into TriCore Environment

We really can't help you if you do not show exactly what command you are using to generate the header, sorry. I am not getting "command" from your words. I am using it in Windows 10 and I added MicroPython src code to a new project. I included genhdr/qstrdefs.generated.h file to project before star...
by SUBBU3881
Thu Feb 15, 2018 6:52 am
Forum: General Discussion and Questions
Topic: Porting into TriCore Environment
Replies: 28
Views: 6486

Re: Porting into TriCore Environment

Please, can you give some clarification here, because I am not able sorting out this problem. I ran .py scripts seperately and added them to my project, but still they are not working. When building minimal, I find that MP_QSTR_ is found near the beginning of the build/genhdr/qstrdefs.generated.h fi...
by SUBBU3881
Thu Feb 15, 2018 6:33 am
Forum: General Discussion and Questions
Topic: Porting into TriCore Environment
Replies: 28
Views: 6486

Re: Porting into TriCore Environment

Everything I am doing in Windows 10 only. I am not using Linux PC to run any commands. Makefiles are generated automatically for the project. The following is the error.. Multiple markers at this line - Symbol 'MP_QSTR_' could not be resolved - each undeclared identifier is reported only once for ea...
by SUBBU3881
Thu Feb 15, 2018 6:14 am
Forum: General Discussion and Questions
Topic: Porting into TriCore Environment
Replies: 28
Views: 6486

Re: Porting into TriCore Environment

Already MICROPY_PY_BUILTINS_PROPERTY is set to 1. The following lines are from "../py/mpconfig.h" // Whether to support property object #ifndef MICROPY_PY_BUILTINS_PROPERTY #define MICROPY_PY_BUILTINS_PROPERTY (1) #endif When reporting errors it is helpful to post the complete error message. As well...
by SUBBU3881
Wed Feb 14, 2018 6:06 am
Forum: General Discussion and Questions
Topic: Porting into TriCore Environment
Replies: 28
Views: 6486

Re: Porting into TriCore Environment

Thanks for the response. I ran python scripts seperately in Linux and I attached them to my project. Now, the "genhdr/qstrdefs.generated.h" holds the following.. QDEF(MP_QSTR_NULL, (const byte*)"\x00\x00\x00" "") QDEF(MP_QSTR_, (const byte*)"\x05\x15\x00" "") QDEF(MP_QSTR__star_, (const byte*)"\x8f\...
by SUBBU3881
Mon Feb 05, 2018 12:54 pm
Forum: General Discussion and Questions
Topic: Porting into TriCore Environment
Replies: 28
Views: 6486

Re: Porting into TriCore Environment

As you said We can build it for Unix/Linux using make command and I tried Unix related stuff only for understanding the compilation flow. But, My requirement is to cross-build it to TriCore Architecture, so I choose HighTec IDE. This IDE is not building python scripts. I separately ran those scripts...
by SUBBU3881
Fri Feb 02, 2018 6:55 am
Forum: Development of MicroPython
Topic: Eclipse setup - missing definitions
Replies: 7
Views: 3367

Re: Eclipse setup - missing definitions

Thanks for the response. I am trying to build MicroPython for Infineon's TriCore Architecture. I downloaded source code of MicroPython from git and I selected "/minimal" to cross build it for TriCore Arch. I didn't found cross-compiler tool for TriCore to build on Linux PC. So, I downloaded Infineon...
by SUBBU3881
Mon Jan 29, 2018 10:00 am
Forum: Development of MicroPython
Topic: Eclipse setup - missing definitions
Replies: 7
Views: 3367

Re: Eclipse setup - missing definitions

Hi, I am also facing similar issue. Can you please help me in resolving the issues. I tried to build MicroPython source code on the directory "/minimal" and I commented STMicro related code in the source because I need for Just MicroPython Interpreter only. I am using Infineon's HighTec IDE to cross...