Search found 5 matches

by johncblacker
Tue Jan 22, 2019 9:03 pm
Forum: WiPy and CC3200 boards
Topic: new WiPy can't connect
Replies: 2
Views: 145

new WiPy can't connect

I just received a new WiPy board, put power to it and I get a blue light flashing about every 4 seconds; however, I can't connect to the board with telnet, nor can I connect my tablet to it's AP - which is asking for a password and I've tried python, micropython and micropythoN to no avail. Telnet s...
by johncblacker
Tue Jan 08, 2019 8:53 pm
Forum: Programs, Libraries and Tools
Topic: uPing - Ping library for MicroPython
Replies: 10
Views: 1813

Re: uPing - Ping library for MicroPython

experimenting a little and found that it definitely doesn't like "usocket.SOCK_RAW"; however, I can print usocket.SOCK_RAW and get an output value of 3...
by johncblacker
Tue Jan 08, 2019 8:35 pm
Forum: Programs, Libraries and Tools
Topic: uPing - Ping library for MicroPython
Replies: 10
Views: 1813

Re: uPing - Ping library for MicroPython

Running into a problem trying to run uping.ping('192.168.0.2') I get: >>> uping.ping('192.168.0.2') Traceback (most recent call last): File "<stdin>", line 1, in <module> File "uping.py", line 49, in ping OSError: [Errno 22] Invalid argument Tried again: >>> import usocket >>> sock = usocket.socket(...
by johncblacker
Mon Nov 12, 2018 12:29 am
Forum: General Discussion and Questions
Topic: The viper code emitter
Replies: 4
Views: 1582

Re: The viper code emitter

I tried rebuilding circuitpython with the setting changed to enable the viper emitter and when I used a decorator, the board flashed it's error led at me pointing to the line with the decorator on it! Once I took it off, the program took off again. How can I find out what's wrong and fix it?
by johncblacker
Sun Nov 11, 2018 8:18 pm
Forum: Other Boards
Topic: Problems building circuitpython no module named huffman
Replies: 1
Views: 251

Problems building circuitpython no module named huffman

I cloned circuitpython and am trying to build mpy-cross, but I get an error during the build that indicates that an
import Huffman failed with a ModuleNoteFoundError: No module named 'huffman'. How do I get around this error? I will also post this on the Adafruit circuitpython forum as well.