Search found 41 matches

by oserror
Sat Mar 06, 2021 6:02 pm
Forum: ESP32 boards
Topic: VL53L0X I2C sensor not recognized after machine.reset()
Replies: 1
Views: 263

Re: VL53L0X I2C sensor not recognized after machine.reset() - Now recognized

Well, I cleaned up my networking code and now the sensor initializes as expected, most of the time. Perhaps I was working the ESP32 too hard before? The "OSError: [Errno 19] ENODEV" error still occurs but not as often. I should have specified the error before. My apologies. My real quibble now is th...
by oserror
Fri Mar 05, 2021 1:45 am
Forum: ESP32 boards
Topic: VL53L0X I2C sensor not recognized after machine.reset()
Replies: 1
Views: 263

VL53L0X I2C sensor not recognized after machine.reset()

I have the ESP32 powered by a 12 Volt power supply -> buck converter -> 6 Volts to VIN and GND pins. The VL53L0X is powered by the 3V3 pin of the ESP32. When connected via WiFi over WebREPL, if I stop main.main() with CTRL-C and call: import machine machine.reset() and reconnect, execution has halte...
by oserror
Wed Jun 17, 2020 10:56 am
Forum: ESP8266 boards
Topic: OTA Firmware: Invalid app size
Replies: 5
Views: 1048

Re: OTA Firmware: Invalid app size

I was signing the ota firmware before sending it with the yaota8266 client. This was my problem. It seems that the client was signing it for me when it was sending the file to the ESP8266 over the air, so it was being signed twice. Compiling the firmware-ota.bin and just sending that over the air wo...
by oserror
Wed Apr 15, 2020 1:49 pm
Forum: ESP8266 boards
Topic: OTA Firmware: Invalid app size
Replies: 5
Views: 1048

Re: OTA Firmware: Invalid app size

I tried this again with the micropython-1.12.tar.xz file available on the micropython.org website (not the git source code I used before with the v1.12 tag). I tried compiling the firmware with 'make ota', erasing the flash with esptool, loading the initial yaota8266.bin firmware at position 0x0 and...
by oserror
Sun Apr 12, 2020 9:26 pm
Forum: ESP8266 boards
Topic: OTA Firmware: Invalid app size
Replies: 5
Views: 1048

OTA Firmware: Invalid app size

I have tried compiling the code both with my own modules in micropython/ports/esp8266/modules and with none of my modules present there. I am able to flash the ESP8266 with the signed firmware-ota.bin.ota file (the second flashing). This is what shows in the terminal when the reset button is pressed...
by oserror
Tue Dec 24, 2019 12:17 am
Forum: ESP8266 boards
Topic: Problem polling a UDP socket on ESP8266 -- works on ESP32
Replies: 3
Views: 1533

Re: Problem polling a UDP socket on ESP8266 -- works on ESP32

No, I didn't. I ended up using TCP instead.

Maybe someone else can figure it out? I'm stuck.
by oserror
Mon Dec 09, 2019 6:59 pm
Forum: ESP8266 boards
Topic: Trouble when calling urlopen() twice in a row
Replies: 1
Views: 621

Re: Trouble when calling urlopen() twice in a row EDIT: also with a single long URL

Okay, it seems that updates can only be sent every 15 seconds or they get rejected. That won't work for me as I'm concerned about battery usage. It still doesn't explain why the full request (values + status -- the entire post/get in one url) only seems to work from the REPL and not when the Wemos D...
by oserror
Sun Dec 08, 2019 8:16 pm
Forum: ESP8266 boards
Topic: Trouble when calling urlopen() twice in a row
Replies: 1
Views: 621

Trouble when calling urlopen() twice in a row

I am having a problem sending two requests to Thingspeak in a row. Below is my code: def SendToThingspeak(host, api_key, result): from urllib.urequest import urlopen # from time import sleep # import urequests as ureq def start_url(): return 'http://%s/update?api_key=%s' % (host, api_key) data_url =...
by oserror
Mon Sep 16, 2019 3:54 pm
Forum: ESP8266 boards
Topic: Verify power draw of Wemos D1 Mini Pro after getting wet under power
Replies: 3
Views: 1046

Re: Verify power draw of Wemos D1 Mini Pro after getting wet under power

Other than the desiccant, did you do anything else to clean the boards? No, I didn't. I'm a novice with electronics. The TP4056 is, unfortunately, securely fastened to the board and I don't think I have enough skill to desolder it. I do have about 10 copies of the main board and enough parts to mak...
by oserror
Thu Sep 12, 2019 4:14 pm
Forum: ESP8266 boards
Topic: Verify power draw of Wemos D1 Mini Pro after getting wet under power
Replies: 3
Views: 1046

Verify power draw of Wemos D1 Mini Pro after getting wet under power

I made a small weather station using a 18650 Lithium battery, a small solar panel, a TP4056, a BME280 and a Wemos D1 Mini Pro. Everything was working fine until a bad storm, when the device fell onto my deck and the rain was on it for a couple of days. I was away and came back to the device not work...