Search found 31 matches

by cyrano1960
Thu May 06, 2021 12:03 pm
Forum: General Discussion and Questions
Topic: dfu-to-bin-tool Linux
Replies: 3
Views: 607

Re: dfu-to-bin-tool Linux

Hi Dave, thanks a lot. When I make my own build it works fine, because I got all binary formats I need (.bin, .hex and .dfu) But I am looking for a simple way to upload the firmware for my students. They use the binary download files on the Micropython page. So they only got the .dfu version and the...
by cyrano1960
Tue May 04, 2021 10:34 am
Forum: General Discussion and Questions
Topic: dfu-to-bin-tool Linux
Replies: 3
Views: 607

dfu-to-bin-tool Linux

Hi there, I have been using the dfuse-demo (STSW-STM32080) for converting the dfu files into bin- oder hex-files but it is replaced by STM32CubProgrammer and this tool doesn´t offer dfu-to-bin-conversion, also the STSW-STM32080 only works on Windows. So is there an alternative for the old dfu file m...
by cyrano1960
Sat Apr 17, 2021 6:56 pm
Forum: Programs, Libraries and Tools
Topic: RTC in ESP8266
Replies: 2
Views: 546

Re: RTC in ESP8266

Hi Kevin,

you hit the bull's eye. I tried it with putty and HTerm and there is a default start time displayed. I work with Thonny and that probably also sets the RTC from ESP to PC time. Thanks for your help.
by cyrano1960
Fri Apr 16, 2021 8:19 pm
Forum: Programs, Libraries and Tools
Topic: RTC in ESP8266
Replies: 2
Views: 546

RTC in ESP8266

I'm kind of at a loss at the moment... :oops: usually it's like you need the RTC time and somehow it's not right, with me it's the other way round. My ESP8266 knows exactly what time it is, but I have no idea how it knows. I don't have wifi configured and it's only connected to the PC via the USB po...
by cyrano1960
Tue Mar 30, 2021 7:34 pm
Forum: Development of MicroPython
Topic: User c module wasn´t found
Replies: 0
Views: 927

User c module wasn´t found

Hi everyone, I have written a first c extension module according to the tutorial and I got it working on STM32 without any problem. But if I built it on rp2 port the external module wasn't add to the compile path. So I can't see any messages that the file was compiled. I have build my firmware + ext...
by cyrano1960
Sun Mar 14, 2021 7:21 pm
Forum: Development of MicroPython
Topic: recommended directory for extensions
Replies: 0
Views: 910

recommended directory for extensions

Hello there, for educational purpose I am trying to extend Mikropython. As a first step I want to extend it with my own py. file and make a frozen .mpy file of it. The process is clear but I wondering if there is a recommended directory for my own extension (i. e. drivers?) Thanks a lot for your hel...
by cyrano1960
Sun Mar 07, 2021 3:01 pm
Forum: Programs, Libraries and Tools
Topic: no password required with ESP32 as WLAN AP
Replies: 2
Views: 426

Re: no password required with ESP32 as WLAN AP

Update:
I found a solution for this but perhaps someone else is running into the same problem.

The password query on ESP32 is only active if the autmode is specified, so this will work for me:

Code: Select all

ap.config(essid=ssid, authmode=network.AUTH_WPA_WPA2_PSK, password=password)
by cyrano1960
Sun Mar 07, 2021 2:04 pm
Forum: Programs, Libraries and Tools
Topic: no password required with ESP32 as WLAN AP
Replies: 2
Views: 426

no password required with ESP32 as WLAN AP

Hello, I have tried the following code snippet to implement a simple WLAN AP with an ESP 32 WifiKit: import network ssid = 'esp32_AP' password = '123456789' ap = network.WLAN(network.AP_IF) ap.active(True) ap.config(essid=ssid, password=password) print(ap.ifconfig()) After that I can see the WiFi ne...
by cyrano1960
Sun Mar 07, 2021 1:55 pm
Forum: General Discussion and Questions
Topic: Size of git repository
Replies: 8
Views: 751

Re: Size of git repository

works perfect... thanks a lot for your valuable support!
by cyrano1960
Sun Mar 07, 2021 1:43 pm
Forum: Development of MicroPython
Topic: make error buildung Micropython for RP2
Replies: 2
Views: 644

Re: make error buildung Micropython for RP2

Hi Jimmo,
sorry for the long delay, but I have been ill for some days... You're right, the WSL was corrupted, even on a Raspberry Pi 3B the build works fine. I have installed the WSL again and now it works perfect.
Thanks for your help!