Search found 4 matches

by bjames28
Tue Sep 17, 2019 6:35 pm
Forum: Drivers for External Components
Topic: Driver for VL53LOX TOF sensor
Replies: 11
Views: 1959

Re: Driver for VL53LOX TOF sensor

Thanks for the tip, the pullups solved the first issue.

The second one was caused by faulty esp8266. With new board all works great.
by bjames28
Mon Sep 16, 2019 4:37 pm
Forum: Drivers for External Components
Topic: Driver for VL53LOX TOF sensor
Replies: 11
Views: 1959

Re: Driver for VL53LOX TOF sensor

Hi All, I am trying to use the VL53LOX TOF sensor with mentioned driver ( https://bitbucket.org/thesheep/micropython-vl53l0x/src/9077f84e25409532b7ef220fa068605c971ba967/vl53l0x.py?at=default&fileviewer=file-view-default ESP8266 with micropython firmware from 05/2019 One issue is that every time I d...
by bjames28
Mon Jul 01, 2019 4:30 pm
Forum: Programs, Libraries and Tools
Topic: umqtt subscribe needs broker response
Replies: 3
Views: 336

Re: umqtt subscribe needs broker response

Thank you pythoncoder! The removal of wait loop helped to solve the actual issue, however - as you predicted - some other problems raised . So finally I had to install a "standard" mosquitto broker (tb-gateway in Thingsboard terminology) in addition to the built-in broker to have a fully compatible ...
by bjames28
Thu Jun 27, 2019 10:06 am
Forum: Programs, Libraries and Tools
Topic: umqtt subscribe needs broker response
Replies: 3
Views: 336

umqtt subscribe needs broker response

Dear All, I use umqtt on ESP8266 to connect to Thingsboard MQTT broker. AFAIK the in current implementation of umqtt, after subscribing to a topic the server must send a response, therefore the client waits for that response. However the Thingsboard built-in MQTT broker does not send any response af...