Search found 4 matches

by dakschnitzer
Tue Aug 13, 2019 3:53 pm
Forum: ESP32 boards
Topic: Trouble connecting to SPI display sh1106
Replies: 8
Views: 179

Re: Trouble connecting to SPI display sh1106

Thanks for following up! I'll give this a try.

Can you clarify what baudrate to use? I'd been using 800,000; you wrote 8,000,000; and in the documentation you linked to it's 80,000,000!

Thanks,
Dan
by dakschnitzer
Mon Aug 12, 2019 5:00 pm
Forum: ESP32 boards
Topic: Trouble connecting to SPI display sh1106
Replies: 8
Views: 179

Re: Trouble connecting to SPI display sh1106

Yes, the i2C OLED on the board itself is working fine. I'm not asking about how this works. My question here is about getting this external SPI display working with the Heltec esp32: https://www.amazon.com/dp/B07QD4JWCN/ref=cm_sw_r_other_apa_i_xyP6Cb749ZDMW As you can see, this is a SPI display. As ...
by dakschnitzer
Sun Aug 11, 2019 8:53 pm
Forum: ESP32 boards
Topic: Trouble connecting to SPI display sh1106
Replies: 8
Views: 179

Re: Trouble connecting to SPI display sh1106

Thanks for the reply. As mentioned, I've gotten the external displays to work with an esp8266 using the code I pasted in. They are SPI displays, not I2C. The OLED display that is internal to the Heltec ESP32 board is I2C, and that works fine. Here's the external SPI display I'm using: https://www.am...
by dakschnitzer
Thu Aug 08, 2019 12:58 am
Forum: ESP32 boards
Topic: Trouble connecting to SPI display sh1106
Replies: 8
Views: 179

Trouble connecting to SPI display sh1106

I was able to get external OLED displays working with a Heltec wifi ESP8266 over SPI with SH1106 as follows: from machine import I2C, Pin, SPI oled_reset_pin = Pin(16, Pin.OUT) spi = SPI(1, baudrate=800000) display = sh1106.SH1106_SPI(128, 64, spi, dc=Pin(0), res=oled_reset_pin, cs=Pin(15)) display2...