Search found 4 matches

by mczubel
Thu Dec 19, 2019 7:01 pm
Forum: ESP8266 boards
Topic: SX127x (LoRa transceiver) driver for (Micro)Python on ESP8266/ESP32/Raspberry_Pi
Replies: 10
Views: 4600

Re: SX127x (LoRa transceiver) driver for (Micro)Python on ESP8266/ESP32/Raspberry_Pi

Wei Lin wrote:
Wed Feb 06, 2019 10:01 pm
The error message means that the SPI communication failed. Sometimes it fails after h/w reset until s/w reset.
I have no oscilloscope hence not sure why it is so.
Hi
I have the same error after deepsleep wake up.
First time work perfect, but after wakeup reset this error appears.
thank
by mczubel
Sat Nov 23, 2019 12:20 pm
Forum: ESP32 boards
Topic: About BLE.gap_connect(esp32-based ubluetooth)
Replies: 41
Views: 3119

Re: About BLE.gap_connect(esp32-based ubluetooth)

I'm newly in esp32 ble, with this firmware: can I set esp32 ble like a beacon?
adv packet with conn posibility
by mczubel
Sat Nov 23, 2019 1:01 am
Forum: ESP32 boards
Topic: About BLE.gap_connect(esp32-based ubluetooth)
Replies: 41
Views: 3119

Re: About BLE.gap_connect(esp32-based ubluetooth)

In ble_uart_peripheral.py file, line 26, I have the AttributeError: 'BLE' object has no attribute 'gatts_set_buffer' How fix it?? What firmware version are you using? (Hit Ctrl-D at the REPL and grab the version that's printed there, or just the filename that you used to flash it would be fine) Sor...
by mczubel
Fri Nov 22, 2019 8:29 pm
Forum: ESP32 boards
Topic: About BLE.gap_connect(esp32-based ubluetooth)
Replies: 41
Views: 3119

Re: About BLE.gap_connect(esp32-based ubluetooth)

Hi
In ble_uart_peripheral.py file, line 26, I have the AttributeError: 'BLE' object has no attribute 'gatts_set_buffer'
How fix it??
1000 thanks