Search found 51 matches

by dps
Tue Dec 17, 2019 7:46 am
Forum: General Discussion and Questions
Topic: [SOLVED]clearing changes and listing resources used
Replies: 2
Views: 384

Re: clearing changes and listing resources used

OH MAN! Thank you so much!
by dps
Sat Dec 14, 2019 6:46 pm
Forum: General Discussion and Questions
Topic: [SOLVED]clearing changes and listing resources used
Replies: 2
Views: 384

[SOLVED]clearing changes and listing resources used

Hello all, I was thinking that it may be a good idea to see how much of your microcontrollers different resources are being used, or "filled" rather. Is there a command to check this, while in a repl? Also, is there a way to clear all of the things that you had done to it, like importing libraries o...
by dps
Sat Dec 07, 2019 2:16 am
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 3425

Re: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)

right! thank you. now im trying to figure out why i cant use idle in the venv. Ive tried looking for an answer through google, but the answer that i keep finding is to do `python -m idlelib` in the venv, but when i do it i get this error: /home/dps/.venv/testing/bin/python: No module named idlelib i...
by dps
Sat Dec 07, 2019 1:55 am
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 3425

Re: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)

well, it looks like i was wrong about that too. I just created a new venv and didnt switch to its directory, and installed esptool via `pip3 install esptool`, and in another term i couldnt find it on my system (except for of course in venv, and in the terminal that was activated with the specific ve...
by dps
Sat Dec 07, 2019 1:48 am
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 3425

Re: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)

haha right. so i just tried to test my theories from before, and it seems that i was wrong about using pip or pip3 having the effect that would install that package system wide. I tried them both, but while i was in the top level of the new venv, and either way, after deactivating, i didnt find it o...
by dps
Sat Dec 07, 2019 1:27 am
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 3425

Re: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)

i think that i may have figured it out. I made sure I was in the actual directory of the venv this time, but i think that using pip3 this time is what made it work as expected. Again, thank you for your help. I think i should stop talking on this thread as its gotten a tad bit off topic from the ori...
by dps
Sat Dec 07, 2019 1:15 am
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 3425

Re: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)

hmm, you know. maybe im doing this all wrong. should i even be using `pip install esptool` in order for the package i install to be only in the venv, or should i be using some other command? maybe i should be using pip3, since i created the venv with python3.
by dps
Sat Dec 07, 2019 1:11 am
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 3425

Re: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)

Heres what im doing: python3 -m venv /path/to/venvdir/specificvenv then I run `source /path/to/venvdir/specificvenv/bin/activate`. then i run `pip install esptool`. should i be doing this while in a specific directory, or should this be getting installed into the virtualenv only (while its activated...
by dps
Fri Dec 06, 2019 11:37 pm
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 3425

Re: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)

hmm, now i seem to be more confused lol. After deactivating (via deactivate) the venv, the esptool.py i am still able to use the esptool.py command, that only had installed via pip, while the venv was activated.
by dps
Fri Dec 06, 2019 11:10 pm
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 3425

Re: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)

haha right on! I have to thank you man, for helping me like this. For some reason I cant understand a lot of what people tell me, or i guess i dont catch on to what they mean when they tell me things or how to do things, but when I was able to understand you though. Thanks again! One thing i did jus...