Search found 9 matches

by JeroenH
Sat Aug 15, 2020 5:44 pm
Forum: Programs, Libraries and Tools
Topic: Cannot get umqtt.robust to work (subscription)
Replies: 8
Views: 469

Re: Cannot get umqtt.robust to work (subscription)

By the way, this is what I'm building: https://tweakers.net/fotoalbum/image/gooPgfTCPGPdcjTui8v2fKBu.jpg It's an ESP32 glued to the back of a 3.2" ILI9341 LCD. The small PCB has a BME280 sensor, the temperature value of which is shown on floor number two. The temperatures of the other rooms in my ho...
by JeroenH
Sat Aug 15, 2020 5:12 pm
Forum: Programs, Libraries and Tools
Topic: Cannot get umqtt.robust to work (subscription)
Replies: 8
Views: 469

Re: Cannot get umqtt.robust to work (subscription)

I'm baffled. I first ran my connect script, which takes perhaps 5s to connect to the LAN. Yeah connecting to the WLAN is always quick on my boards too. I can only suggest putting in print statements to find out what's taking the time. I was afraid it might come to that. I'll print/timestamp the rel...
by JeroenH
Thu Aug 13, 2020 1:36 pm
Forum: Programs, Libraries and Tools
Topic: Cannot get umqtt.robust to work (subscription)
Replies: 8
Views: 469

Re: Cannot get umqtt.robust to work (subscription)

It's all different than I thought. It works 100% of the time, the startup is just very, very slow. I've now done three tests where I've booted up the board, waited until it seemingly hung (or even got to the check loop), sent a message to test/test with a time stamp and watched some videos on YT. Th...
by JeroenH
Thu Aug 13, 2020 9:26 am
Forum: Programs, Libraries and Tools
Topic: Cannot get umqtt.robust to work (subscription)
Replies: 8
Views: 469

Re: Cannot get umqtt.robust to work (subscription)

It works here on ESP32 with one change: Yeah, I removed that if statement altogether in the code in my second post. Just to be sure I copy/pasted your code and ran it. I get the same hit and miss behaviour at startup, though :( It just won't start reliably. I'm pulling my hair out why this could be...
by JeroenH
Thu Aug 13, 2020 7:12 am
Forum: Programs, Libraries and Tools
Topic: Cannot get umqtt.robust to work (subscription)
Replies: 8
Views: 469

Re: Cannot get umqtt.robust to work (subscription)

I've gotten a little further. I've changed the script to print a short progress message between all the separate mqtt commands, to see how long things take, where it goes wrong, etc. print("Start script") from umqtt.robust import MQTTClient def sub_callback(topic,payload): print("test") print(payloa...
by JeroenH
Wed Aug 12, 2020 2:09 pm
Forum: Programs, Libraries and Tools
Topic: Cannot get umqtt.robust to work (subscription)
Replies: 8
Views: 469

Cannot get umqtt.robust to work (subscription)

Hello, for the past couple of days I've been googling, tinkering, trying, cursing, taking breaks etc. but I'm stuck. I have a generic ESP32 board running the latest Micropython. I have installed umqtt.robust with upip, and very quickly and easily I got publishing a message to my Mosquitto broker to ...
by JeroenH
Tue Aug 11, 2020 12:30 pm
Forum: Programs, Libraries and Tools
Topic: One ESP32 as Master and several as client - how to transfer data...
Replies: 1
Views: 448

Re: One ESP32 as Master and several as client - how to transfer data...

MQTT sounds like a good option. I'm building something that sounds similar to your project. I want to have ESP32-based temperature/relative humidity/PIR sensors in all the rooms, each with their own small OLED display. The living room unit will have an ESP32 connected to a larger LCD (or maybe an e-...
by JeroenH
Sat May 23, 2020 7:25 pm
Forum: Drivers for External Components
Topic: Waveshare 2.13in display v2 driver
Replies: 11
Views: 3635

Re: Waveshare 2.13in display v2 driver

Have a read of their GitHub repo . That link is for your specific epaper range's repo and it appears most of your SPI pins are set up correctly. Many thanks! This at least allows me to confirm that I use the correct pins. That removes one uncertainty from the equation. I've written and tested a few...
by JeroenH
Sat May 23, 2020 8:40 am
Forum: Drivers for External Components
Topic: Waveshare 2.13in display v2 driver
Replies: 11
Views: 3635

Re: Waveshare 2.13in display v2 driver

Hi Mattstock, Have you made any progress on your the driver? I have an ESP32 TTGO T5 V2.0 board with 2.13in e-ink display. I think it has the same GDEH0213B72 chip. I tried mcauser’s driver. The display flashes black and white a couple of times but only displays random black and white pixels, which...