Search found 26 matches

by Niallp
Wed Feb 15, 2017 6:21 am
Forum: WiPy and CC3200 boards
Topic: CC3200 build environment
Replies: 2
Views: 1370

CC3200 build environment

After reviewing the readme, I should be able to build firmware for the WiPy1 and CC3200 Launchpad using the toolchain from gcc-arm-embedded and it certainly seems to work most of the way ... builds complete with no errors and the board is mostly functional. I can't get the builtin FTP server working...
by Niallp
Thu Jun 23, 2016 3:38 pm
Forum: WiPy and CC3200 boards
Topic: I2C baudrate oddity?
Replies: 2
Views: 3891

Re: I2C baudrate oddity?

9600 seems like a very slow clock rate for I2C, is this an asynchronous (ie RS232) device ? I suppose there is probably an I2C UART that will do the job for you but I suspect you weren't intending that ...

... Niall
by Niallp
Thu Jun 23, 2016 3:34 pm
Forum: WiPy and CC3200 boards
Topic: Wipy setup access
Replies: 1
Views: 3498

Re: Wipy setup access

I'm unclear what you are refering to ... ftp server or telnet console ?

... Niall
by Niallp
Sun Jun 19, 2016 5:19 pm
Forum: WiPy and CC3200 boards
Topic: Reflash via jtag ?
Replies: 0
Views: 4205

Reflash via jtag ?

I have a wipy which only boots in full safemode, the sense GPIO probably stuck high (in hindsight that simple jumper for safe mode was too simple :-/ ... has anyone had success reflashing the bootloader ? I'm thinking if I remap the safe mode pin the board could be used again.

... Niall
by Niallp
Wed Jun 08, 2016 4:40 am
Forum: WiPy and CC3200 boards
Topic: Pymakr on this forum
Replies: 6
Views: 4737

Re: Pymakr on this forum

[quote="mbevilacqua"]Silly question but still haven't figured how to use pymakr to automatically upload code and execute it... Got my project setup, for the wipy setup, can use the lower tab to interact with the wipy but running my project seems to try to run it locally instead of pushing it to the ...
by Niallp
Wed Jun 08, 2016 4:30 am
Forum: Programs, Libraries and Tools
Topic: pymaker ?
Replies: 2
Views: 4170

pymaker ?

Just discovered the pymakr dev environment on pycom (https://www.pycom.io/solutions/pymakr/) and while it installed OK (Ubuntu 16.04 64 bit) it seems unable to establish a connection with my board. Connection is fine via picocom on the expansion board serial port or via vanilla telnet or ftp, I've t...