Search found 85 matches

by roland_vs
Mon Nov 06, 2017 6:28 pm
Forum: Hardware Projects
Topic: Project Help Pool Motor
Replies: 16
Views: 3655

Re: Project Help Pool Motor

As a suggestion I would like to add that you can parallel relays and SCR with the benefit of dealing with the inrush when activating the SCR and have a (smaller) relay for holding. Power dissipation would be minimal and the fan can be omitted. Also using some Pt1000/Pt500//Pt100 and a little bridge ...
by roland_vs
Mon Oct 16, 2017 11:44 am
Forum: Other Boards
Topic: [IntelCurie] Does anyone work on porting uPy to this?
Replies: 3
Views: 1091

Re: [IntelCurie] Does anyone work on porting uPy to this?

Dear Peter, I also placed a red flag at every Curie, Joule, Edison, etc. However it seems (and was told by the Intel IoT guys in Ireland) that Intel withdraws from producing boards that support all the different inventor names, however are committed to produce the chips and SoC's. They leave it up t...
by roland_vs
Thu Oct 05, 2017 8:10 am
Forum: Other Boards
Topic: [IntelCurie] Does anyone work on porting uPy to this?
Replies: 3
Views: 1091

[IntelCurie] Does anyone work on porting uPy to this?

Dear,

I'm looking into using the Intel Curie SoC. It would be great if it could run mpy. The CurieSDK also supports ZephyrOS.

Has anyone looked at the possibility and rejected it?
Is anyone working on such a port?

R
by roland_vs
Wed Sep 27, 2017 9:52 am
Forum: Other Boards
Topic: [STM32L476DISCO] RTC not ticking
Replies: 5
Views: 1496

Re: [STM32L476DISCO] RTC not ticking

@pythoncoder Dear Peter, Indeed I noticed when I put my finger on the capacitors next to the 32kHz Oscillator REPL via the USB doesn't respond, and removing the finger everything works again. I tested the L476 port on the original STM32L476DISCO (reference) and two boards of my own making. They all ...
by roland_vs
Tue Sep 26, 2017 9:18 pm
Forum: Other Boards
Topic: STM32L467DISC port not working?
Replies: 16
Views: 4599

Re: STM32L467DISC port not working?

To be complete: The difference between working and not working is entirely due to the 8-byte alignment of the generated code of the L476 port. If you use DFU-UTIL to program the firmware.dfu you may run into problems when the file is not padded to fulfil the mentioned need. AN2606 of STM for further...
by roland_vs
Tue Sep 26, 2017 12:37 pm
Forum: Other Boards
Topic: [STM32L476DISCO] RTC not ticking
Replies: 5
Views: 1496

[STM32L476DISCO] RTC not ticking

Dear all, Anyone experienced the fact that the RTC is not running? import pyb pyb.RTC().datetime() should change every time you issue this command. Also setting the clock takes about a second or so before the prompt returns, but no changes to the registers at all. The default time is stuck at (2000,...
by roland_vs
Mon Sep 25, 2017 4:07 pm
Forum: Drivers for External Components
Topic: Which Servo's
Replies: 5
Views: 1194

Which Servo's

Hello,

Micropython supports the control of servo's.
Are there any particular type/brand of servo's that work well with the py-board?

Regards,

Roland
by roland_vs
Sun Jun 11, 2017 12:52 pm
Forum: General Discussion and Questions
Topic: iPad version?
Replies: 1
Views: 1004

iPad version?

Dear all,

Is somebody working on an Apple iPad version of micropython?

Regards,

Roland
by roland_vs
Wed Jun 07, 2017 10:25 am
Forum: Other Boards
Topic: STM32L467DISC port not working?
Replies: 16
Views: 4599

Re: STM32L467DISC port not working?

It works, however using JTAG to program the image rather than dfu-util, the aforementioned "patch" combined with the randomness of dfu-util showed that it worked, but was not the root cause. So if I have time I will check other "dfu" programs (like python version) to see at which side the problem re...
by roland_vs
Tue May 30, 2017 1:50 pm
Forum: Other Boards
Topic: STM32L467DISC port not working?
Replies: 16
Views: 4599

Re: STM32L467DISC port not working?

I have it working now. It seems that the dfu-util/bootloader via USB experiences some problems. It does load w/o any errors, but the code does not run as expected: - constantly rebooting when USB cable attached - when USB removed REPL via UART can be used, however no file system, crashes randomly wh...