Search found 250 matches

by shaoziyang
Fri Jun 03, 2016 1:37 am
Forum: Other Boards
Topic: ADC not working on L4
Replies: 3
Views: 1635

Re: ADC not working on L4

Yes, it is not work in STM32F7DISC too.
by shaoziyang
Wed May 25, 2016 3:12 pm
Forum: Other Boards
Topic: UART baudrate error in STM32L476
Replies: 3
Views: 1963

UART baudrate error in STM32L476

When I set uart baudrate, it will prompt :

>>> uart=UART(2)
>>> uart.init(9600)
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
ValueError: set baudrate 2459173 is not within 5% of desired value

But baudrate is set correctly and uart works.
by shaoziyang
Sun May 08, 2016 5:04 pm
Forum: Other Boards
Topic: STM32F7DISC's I2C1 is not work in V1.8
Replies: 0
Views: 2163

STM32F7DISC's I2C1 is not work in V1.8

In micropython v1.8, NUCLEO_F411RE's I2C1 is work now, but STM32F7DISC's I2C1 is still not work. I use a DS3231 RTC mudule, it is work fine with NUCLEO_F411RE. I use code below to test it, it will read second register, if it works, it will show a continuous change number. MicroPython v1.8 on 2016-05...
by shaoziyang
Wed May 04, 2016 12:52 pm
Forum: Other Boards
Topic: I2C1 in Nucleo-F411RE does not work
Replies: 2
Views: 1317

Re: I2C1 in Nucleo-F411RE does not work

I don't see anything that would explain why it shouldn't work. Are you using the latest firmware? Did you add pullup resistors? After you've configured I2C1 could you tell me what the output of the following is: pyb.Pin('B6') pyb.Pin('B7') I connect NUCLEO-F411 board with a RTC module (DS3231) with...
by shaoziyang
Wed May 04, 2016 3:00 am
Forum: Other Boards
Topic: I2C1 in Nucleo-F411RE does not work
Replies: 2
Views: 1317

I2C1 in Nucleo-F411RE does not work

I try I2C1 in Nucelo F411RE board, with PB6/PB7 pin, but it is not work, return nothing. Same code is working fine in I2C2.
by shaoziyang
Wed May 04, 2016 2:58 am
Forum: Other Boards
Topic: Does micropython in STM32F4DISC support Accel?
Replies: 2
Views: 1136

Does micropython in STM32F4DISC support Accel?

STM32F4DISC has LIS3DS sensor, but pyb.Accel() does not work.
by shaoziyang
Sat Apr 30, 2016 2:02 pm
Forum: Other Boards
Topic: Build STM32L476DISC error
Replies: 1
Views: 1130

Build STM32L476DISC error

I build STM32L476DISC, and get below error message. CC ../lib/utils/printf.c CC main.c In file included from hal/l4/inc/stm32l4xx_hal_def.h:49:0, from hal/l4/inc/stm32l4xx_hal_rcc.h:47, from boards/STM32L476DISC/stm32l4xx_hal_conf.h:194, from hal/l4/inc/stm32l4xx_hal.h:48, from ./mpconfigport.h:216,...
by shaoziyang
Tue Apr 19, 2016 2:17 am
Forum: Other Boards
Topic: help DS18x20 sensor in STM32F7DISC
Replies: 1
Views: 1079

Re: help DS18x20 sensor in STM32F7DISC

I have solve this problem. It cause by onewire delay. Open onewire.py, and modify

self.write_delays = (1, 40, 40, 1)
self.read_delays = (1, 1, 40)

to

self.write_delays = (6, 64, 60, 10)
self.read_delays = (6, 9, 55)

then DS1820 will work in STM32F7DISC now.
by shaoziyang
Mon Apr 18, 2016 8:48 am
Forum: Other Boards
Topic: I2C1 is not work correctly in STM32F7DISC
Replies: 0
Views: 1682

I2C1 is not work correctly in STM32F7DISC

I use I2C1 in STM32F7DISC to control a RTC chip (DS1307), I2C may work, but data is not correctly. Same chip and code is work fine with PYB v1.0.
by shaoziyang
Sun Apr 17, 2016 2:04 pm
Forum: Other Boards
Topic: help DS18x20 sensor in STM32F7DISC
Replies: 1
Views: 1079

help DS18x20 sensor in STM32F7DISC

I build micropython 1.7 with STM32F7DISC board, it works fine. When I connect a DS1820 sensor, it is not work, but Same DS1820 sensor is work in pyboard v1.0. >>> # STM32F7DISCO >>> from pyb import Pin >>> Pin('D2', Pin.OUT_PP).low() >>> Pin('D0', Pin.OUT_PP).high() >>> pyb.delay(100) >>> >>> from d...