Search found 359 matches

by devnull
Wed Sep 04, 2019 10:23 am
Forum: General Discussion and Questions
Topic: umqtt_simple - bytes index out of range new error
Replies: 7
Views: 482

Re: umqtt_simple - bytes index out of range new error

OK, here's some debug info that has been added to mqtt_simple: This is the code from mqtt_simple: self.sock.write(premsg, i + 2) self.sock.write(msg) print('dbug-msg:',hex(len(msg)), hexlify(msg, ":")) self._send_str(self.client_id) if self.lw_topic: self._send_str(self.lw_topic) self._send_str(self...
by devnull
Wed Sep 04, 2019 7:19 am
Forum: General Discussion and Questions
Topic: umqtt_simple - bytes index out of range new error
Replies: 7
Views: 482

Re: umqtt_simple - bytes index out of range new error

Hi;

Thanks so much for offering help Jimmo, I have yet to debug myself, this is already mounted to a PCB and boxed.

I need to first do some basic debugging and potentially create some steps to replicate.

Will get beck to you once I have done that.
by devnull
Tue Sep 03, 2019 11:34 pm
Forum: General Discussion and Questions
Topic: umqtt_simple - bytes index out of range new error
Replies: 7
Views: 482

Re: umqtt_simple - bytes index out of range new error

When I revert back to an older build, the problem goes away and connection is successful every time with no errors:

Code: Select all

MicroPython v1.9.3-1869-ga9b1d3ca3
Using my latest, I get the bytes index out of range errors, and it very very rarely connects:

Code: Select all

micropython v1.11-218-g3eff81288
by devnull
Tue Sep 03, 2019 1:13 pm
Forum: General Discussion and Questions
Topic: umqtt_simple - bytes index out of range new error
Replies: 7
Views: 482

Re: umqtt_simple - bytes index out of range new error

Hello Jimmo, thanks for helping.

Sorrie, specifying the line number was misleading as I maye have added some comments to the top of the file, this in fact is line 84:

Code: Select all

assert resp[0] == 0x20 and resp[1] == 0x02
Cheers

PeterC
by devnull
Tue Sep 03, 2019 12:00 pm
Forum: General Discussion and Questions
Topic: umqtt_simple - bytes index out of range new error
Replies: 7
Views: 482

umqtt_simple - bytes index out of range new error

Just updated micropython on the SF2 and are now noticing mqtt errors (umqtt_simple line 84) during the connection process. This tries to connect 3 times and if it fails will goto sleep and try again later. But I don't recall seeing this "bytes index out of range" error ever before, and I have been u...
by devnull
Thu Jul 04, 2019 11:05 am
Forum: General Discussion and Questions
Topic: REPL - disable echo
Replies: 1
Views: 148

REPL - disable echo

I am talking to the device using nodejs serialport, and I need to disable the reply echo of the command entered.

Can this be done ??
by devnull
Tue Jul 02, 2019 11:31 am
Forum: ESP32 boards
Topic: [Solved] Cannot Build Latest using esp-idf 6b3da6b
Replies: 3
Views: 198

Re: Cannot Build Latest using esp-idf 6b3da6b

Thanks Robert;

Yes, fully updated including the toolchain.

Silly mistake, needed to make clean

:oops:
by devnull
Mon Jul 01, 2019 1:19 pm
Forum: ESP32 boards
Topic: [Solved] Cannot Build Latest using esp-idf 6b3da6b
Replies: 3
Views: 198

[Solved] Cannot Build Latest using esp-idf 6b3da6b

Just updated uPython and the esp-idf to 6b3da6b188 (3.3 Beta) and cannot get it to build anymore. /nfs/qnap/dev/uPython/build/micropython/ports/esp32/esp-idf/components/efuse/esp32/esp_efuse_table.c:26:21: error: 'CONFIG_EFUSE_MAX_BLK_LEN' undeclared here (not in a function) #define MAX_BLK_LEN CONF...
by devnull
Tue May 07, 2019 12:59 pm
Forum: ESP32 boards
Topic: Build Error - python2: Command not found
Replies: 2
Views: 233

Re: Build Error - python2: Command not found

@jimmo - thanks so much, yes that worked :-)
by devnull
Tue May 07, 2019 12:13 pm
Forum: ESP32 boards
Topic: Build Error - python2: Command not found
Replies: 2
Views: 233

Build Error - python2: Command not found

Unable to build esp32, I only have python3 installed and don't want to install python 2.7 as it is being deprecated soon. I have tried to force using python 3 with PYTHON=python3 but as you can see the kake command is still calling python 2 # make V=1 PYTHON=python3 Create build/partitions.bin pytho...