Search found 14 matches

by kid06
Sat Mar 04, 2017 6:44 pm
Forum: Other Boards
Topic: MCUDev Black STM32F407VET6 + STM32F407ZET6 dev boards
Replies: 152
Views: 57926

Re: Black STM32F407VET6 + STM32F407ZET6 dev boards

Ok, as I supposed, wrong timings.

@lmamakos, there's a wrong definition in your stm32f4xx_hal_conf.h file

line 104, frequency of external osc should be 8Mhz not 25 (at least on my board).

After change servo and delay goes ok. RTC not tested, yet.

thank you
by kid06
Sat Mar 04, 2017 5:40 pm
Forum: Other Boards
Topic: MCUDev Black STM32F407VET6 + STM32F407ZET6 dev boards
Replies: 152
Views: 57926

Re: Black STM32F407VET6 + STM32F407ZET6 dev boards

I did some more investigations.

pyb.delay(nnn) seems 3x slower e.g. like 3xnnn

I'm using lmamakos patched source. Maybe a timing problem -> problem with servo.
by kid06
Sat Mar 04, 2017 10:37 am
Forum: Other Boards
Topic: MCUDev Black STM32F407VET6 + STM32F407ZET6 dev boards
Replies: 152
Views: 57926

Re: Black STM32F407VET6 + STM32F407ZET6 dev boards

RTC exibits reset to default time on power cycle. Can someone confirm?
by kid06
Fri Mar 03, 2017 4:30 pm
Forum: Other Boards
Topic: MCUDev Black STM32F407VET6 + STM32F407ZET6 dev boards
Replies: 152
Views: 57926

Re: Black STM32F407VET6 + STM32F407ZET6 dev boards

I confirm STM32F407VET6 works fine. Compiled MicroPython in Docker(ized) Ubuntu on orangePI ONE :D . Uploaded firmware.dfu via dfu-util. Tested servo on PA0 (->X1, pyb.Servo(1)) and PA2 (->X3, pyb.Servo(3)). I see some reaction but totally wrong. This is my day 0 on MicroPython. Looks very promising...