Search found 18 matches

by Tillmario
Wed Nov 21, 2018 11:07 am
Forum: ESP8266 boards
Topic: Sending temperature data to....somwhere
Replies: 8
Views: 907

Re: Sending temperature data to....somwhere

I'll make it easy for you: use mqtt and check https://www.home-assistant.io/ Thanks that is very helpful. But for how to use mqtt on your esp8266 you actually have to use google or the forum search and read about it yourself ;) I didn't expect anyone to do that. It's just hard to look for something...
by Tillmario
Wed Nov 21, 2018 8:17 am
Forum: ESP8266 boards
Topic: Sending temperature data to....somwhere
Replies: 8
Views: 907

Re: Sending temperature data to....somwhere

Tillmario wrote:
Tue Nov 20, 2018 5:31 pm
My problem now ist.... how to send it somewhere via wifi?
by Tillmario
Tue Nov 20, 2018 5:31 pm
Forum: ESP8266 boards
Topic: Sending temperature data to....somwhere
Replies: 8
Views: 907

Sending temperature data to....somwhere

Hi, thanks to the help of this forum i flashed MicroPython v1.9.1-8 on my ESP2866. The board is connected to my Wifi. I succesfully conected a DHT22, written a script (http://docs.micropython.org/en/latest/esp8266/quickref.html#dht-driver) and got my temperature as an output. My problem now ist.... ...
by Tillmario
Tue Nov 20, 2018 5:19 pm
Forum: ESP8266 boards
Topic: Trouble flashing the image
Replies: 8
Views: 713

Re: Trouble flashing the image

HermannSW wrote:
Tue Nov 20, 2018 1:26 pm
What does "gc.mem_free()" show on your module just after power on?
25920

I think there was some "lua" firmware preinstalled :roll:

Thanks for all the help.
by Tillmario
Mon Nov 19, 2018 11:35 pm
Forum: ESP8266 boards
Topic: Trouble flashing the image
Replies: 8
Views: 713

Re: Trouble flashing the image

Update:
Putty -> Connections -> Serial
I set Flow-Control to "None", now I can write. :)
by Tillmario
Mon Nov 19, 2018 10:01 pm
Forum: ESP8266 boards
Topic: Trouble flashing the image
Replies: 8
Views: 713

Re: Trouble flashing the image

Thanks for the help so far. This sheds light on some things. I now succesfully flashed the MicroPython firmware. Afterwards i connected via Putty to my COM5 Port @115200 Speed. This is shown. {l$ܞ|▒l▒| ▒ d▒b|▒▒▒{▒#▒ #▒▒o▒lNn▒▒cbp▒▒#$`rlp▒o▒ ▒ $ B o▒|▒l$ #▒|~▒o▒l▒▒$`▒o▒{lnr▒▒▒n Bl p▒n▒ r▒ܜ▒▒ # o▒|$l ...
by Tillmario
Mon Nov 19, 2018 5:30 pm
Forum: ESP8266 boards
Topic: Trouble flashing the image
Replies: 8
Views: 713

Re: Trouble flashing the image

>"How did you connect to the module?" via Putty >"MicroPython runs by default with 115200 baud." That's how i did it with Putty, the video explained it like that as well. I have more than one board. I figured out, that with another one I can connect. After connecting I get the following text, but i ...
by Tillmario
Mon Nov 19, 2018 3:15 pm
Forum: ESP8266 boards
Topic: Trouble flashing the image
Replies: 8
Views: 713

Trouble flashing the image

Hello, i bought a NodeMCU ESP8266 and wanted to try MicroPyhton, since I am familiar with Python on my Raspberry Pi. The ESP8266 is connected via USB to my PC (Windows 10). I'm using this Tutorial. http://docs.micropython.org/en/latest/esp8266/tutorial/intro.html#intro But I'm stuck at 1.4 Is "espto...