Search found 32 matches

by smith.randallscott
Tue Jul 16, 2019 3:15 pm
Forum: ESP32 boards
Topic: main.py does not appear to working after boot
Replies: 50
Views: 5566

Re: main.py does not appear to working after boot

How do I get similar with what that code actually means, especially the frozen part? Also main.py is in the root of the file system has far as I can tell.
>>> os.listdir('')
['boot.py', 'main.py']
>>>
by smith.randallscott
Tue Jul 16, 2019 2:22 pm
Forum: ESP32 boards
Topic: main.py does not appear to working after boot
Replies: 50
Views: 5566

Re: main.py does not appear to working after boot

Main only executes when I am already logged into the REPL and issue machine.reset() or cmd+D or soft reset. When I do that all works fine. If I power cycle the unit main.py does not execute. I don't know how to further troubleshoot this. Any help would be appreciated.
by smith.randallscott
Sun Jul 14, 2019 8:59 pm
Forum: ESP32 boards
Topic: main.py does not appear to working after boot
Replies: 50
Views: 5566

Re: main.py does not appear to working after boot

I created the main.py on the raspberryPI, then transferred it to the esp32 by being already logged into the ESP32, then using the command "cp main.py /pyboard/" each time that I modify main.py I use the same procedure. I edit the file on the Pi and then transfer it to the ESP32 using the cp command....
by smith.randallscott
Sun Jul 14, 2019 7:18 pm
Forum: ESP32 boards
Topic: main.py does not appear to working after boot
Replies: 50
Views: 5566

Re: main.py does not appear to working after boot

I do see the normal >>>. Is there any other reason main.py wouldn't be called? So far I have set a variable at the last line of boot.py and I see this variable when I run dir() from the REPL, I also set a variable on the first line of main.py and I do not see this when I run dir()
by smith.randallscott
Sun Jul 14, 2019 5:42 pm
Forum: ESP32 boards
Topic: main.py does not appear to working after boot
Replies: 50
Views: 5566

Re: main.py does not appear to working after boot

Moving items between boot.py and main.py leads me to conclude that main.py is not being executed. How can I look under the hood and figure this out? How do I check PYEXEC_MODE_FRIENDLY_REPL mode? How do I determine if raw mode (Ctrl.A) is set? should I try to call main.py explicitly?
by smith.randallscott
Sun Jul 14, 2019 1:46 pm
Forum: ESP32 boards
Topic: main.py does not appear to working after boot
Replies: 50
Views: 5566

Re: main.py does not appear to working after boot

I only need the repl during testing and troubleshooting. It will run unattended
by smith.randallscott
Sun Jul 14, 2019 1:15 pm
Forum: ESP32 boards
Topic: main.py does not appear to working after boot
Replies: 50
Views: 5566

Re: main.py does not appear to working after boot

So in the case where I want to continuously monitor something, in this case a temperature; how do I accomplish that? Do I call a function from main that initiates an never ending loop? Do I use the scheduler module instead? What would be the best practice? Also based on my experience, in this specif...
by smith.randallscott
Sat Jul 13, 2019 7:49 pm
Forum: ESP32 boards
Topic: main.py does not appear to working after boot
Replies: 50
Views: 5566

Re: main.py does not appear to working after boot

I moved everything from main.py to boot.py and it seems to be working after a reboot now; however now I don't seem to be able to connect to the ESP32 with rshell. I suspect its because of the never ending while loop (in boot.py). Can anyone confirm this?
by smith.randallscott
Fri Jul 12, 2019 1:02 pm
Forum: ESP32 boards
Topic: main.py does not appear to working after boot
Replies: 50
Views: 5566

Re: main.py does not appear to working after boot

No luck getting the led to energize, on boot. I am baffled because the code works each time I connect remotely from a windows 7 machine to the RaspberryPi using MobaXterm, then connect to the ESP32 using rshell everything works perfectly. When I initially connect I only have a blank RELP >>>, at thi...