Search found 14 matches

by zmaier
Tue Jun 18, 2019 12:57 pm
Forum: Programs, Libraries and Tools
Topic: [SOLVED] question on mpy-cross
Replies: 21
Views: 3872

Re: [SOLVED] question on mpy-cross

Hi, any change to get a running mpy-cross.exe compatilble with windows 64Bit?
by zmaier
Fri May 31, 2019 7:00 am
Forum: General Discussion and Questions
Topic: OSError: no available NIC after Soft-Reset
Replies: 5
Views: 1016

Re: OSError: no available NIC after Soft-Reset

I am using a WiPy 3.0.

wlan.mode(WLAN.STA) at any boot type,
I read somewhere, that the connection (telnet repl) will get lost wenn setting the wlan-mode?
by zmaier
Fri May 31, 2019 6:44 am
Forum: General Discussion and Questions
Topic: urequests and timeout?
Replies: 2
Views: 556

urequests and timeout?

Hi everyone. when loosing the wlan-connection (e.g. i turn of the router) my programm hangs at : response = urequests.post(db, data=payload,timeout=timeout_sec) it is not raising a exception, the program hangs for ever at this line. Any idea why? How do you implement a simple post-command? THX Marti...
by zmaier
Thu May 16, 2019 12:47 pm
Forum: General Discussion and Questions
Topic: OSError: no available NIC after Soft-Reset
Replies: 5
Views: 1016

OSError: no available NIC after Soft-Reset

Hello, i have a problem, hopefully you can help me. After a soft-reset (CTRL-D in REPL), i get the error that there is no available NIC when using the urequest.post command. After a hard-reset everything is working fine. Propably the re-initialization of the wifi interface is not done right, but the...