Search found 20 matches

by djipey
Fri Jan 17, 2020 10:39 pm
Forum: ESP32 boards
Topic: ESP32S and adapter board
Replies: 11
Views: 1471

Re: ESP32S and adapter board

I might be interested by the adapters you mentioned if they are plug-n play, without soldering.

In the mean time, I would like to try and make my adapters work. Do I need the resistors?
by djipey
Fri Jan 17, 2020 8:41 pm
Forum: ESP32 boards
Topic: ESP32S and adapter board
Replies: 11
Views: 1471

ESP32S and adapter board

Hi, I'm trying to upload micropython on my ESP32 WROOM (the bare chip). I got it from here, with the adapter board: https://www.banggood.com/ESP32-ESP-WROOM-32-IoT-Wifi-WLAN-BLE-ModuleESP-32S-Adapter-Pinboard-Converter-Board-p-1468284.html?rmmds=myorder&cur_warehouse=CN I soldered the chip on the ad...
by djipey
Tue Jan 14, 2020 9:09 pm
Forum: Programs, Libraries and Tools
Topic: umqtt.robust: ensure that broker received the message
Replies: 10
Views: 2654

Re: umqtt.robust: ensure that broker received the message

By the way, I never replied to the thread. I found a way to solve my problem: with uping and a nightly firmware (uping needs a recent implementation of websockets to work properly), I can first ping the broker. If a ping can reach it, I send the data. If not, I try to reconnect to the network. It wo...
by djipey
Sun Jan 05, 2020 6:50 pm
Forum: ESP8266 boards
Topic: ESP12e: analog reading not working with voltage divider
Replies: 4
Views: 499

Re: ESP12e: analog reading not working with voltage divider

I got the divider to work, by using 2x 220k ohm resistors as R1 and a 470k ohm as R2. I span the range 420/975 mv (in water, in air) vs 1.2/2.5V (water, air) directly from the sensor. Thanks for spotting impedance was the problem.
by djipey
Sun Jan 05, 2020 5:32 pm
Forum: ESP8266 boards
Topic: ESP12e: analog reading not working with voltage divider
Replies: 4
Views: 499

Re: ESP12e: analog reading not working with voltage divider

I'm a beginner in electronics so I'm not sure about what "Can the sensor drive an impedance as low as 320Ω?" really means. But I can measure the voltages coming from the sensor, I have a multimeter. Directly from the sensor (no voltage divider), I have 2.5V when the sensor is in the air, and 1.2V wh...
by djipey
Sun Jan 05, 2020 3:53 pm
Forum: ESP8266 boards
Topic: ESP12e: analog reading not working with voltage divider
Replies: 4
Views: 499

ESP12e: analog reading not working with voltage divider

Hi, I'm trying to read from an analog sensor (a capacitive soil moisture sensor). I'm using a ESP12E, not a development board, so the ADC pin can only take 1V max. Since my sensor can output up to 3V, I need a voltage divider to not fry my board. Here is my wiring: https://imgur.com/4NYRfzt Could yo...
by djipey
Sat Jan 04, 2020 6:30 pm
Forum: ESP32 boards
Topic: [SOLVED] Waveshare eink 2in7 not displaying anything
Replies: 3
Views: 475

Re: Waveshare eink 2in7 not displaying anything

It turned out it was just the baudrate, mine was too high.

It works with:

Code: Select all

# SPIV on ESP32
sck = Pin(18)
miso = Pin(19)
mosi = Pin(23)
dc = Pin(22)
cs = Pin(5)
rst = Pin(21)
busy = Pin(4)
spi = SPI(2, baudrate=100000, polarity=0, phase=0, sck=sck, mosi=mosi, miso=miso)

by djipey
Sat Jan 04, 2020 3:01 pm
Forum: ESP32 boards
Topic: [SOLVED] Waveshare eink 2in7 not displaying anything
Replies: 3
Views: 475

Re: Waveshare eink 2in7 not displaying anything

I don't think the miso pin is important, since the screen isn't supposed to send any data. But I also tried this wiring/code: sck = Pin(18) miso = Pin(19) mosi = Pin(23) dc = Pin(22) cs = Pin(5) rst = Pin(21) busy = Pin(4) spi = SPI(2, baudrate=80000000, polarity=0, phase=0, firstbit=0, bits=8, sck=...
by djipey
Sat Jan 04, 2020 1:00 pm
Forum: ESP32 boards
Topic: [SOLVED] Waveshare eink 2in7 not displaying anything
Replies: 3
Views: 475

[SOLVED] Waveshare eink 2in7 not displaying anything

Hi, I have a waveshare eink screen 2.7 inches (black and white, no red). I'm trying to make it work with micropython and my ESP32 board. I tested the screen first with an arduino uno board and the code provided here: https://www.waveshare.com/wiki/2.7inch_e-Paper_HAT#Arduino_UNO and the screen works...
by djipey
Sun Dec 01, 2019 3:16 pm
Forum: Programs, Libraries and Tools
Topic: umqtt.robust: ensure that broker received the message
Replies: 10
Views: 2654

umqtt.robust: ensure that broker received the message

Hi, this is my first post on the forum. I'm familiar with Python and I'm trying to send data from my ESP32 board to a Mosquitto broker, with the MQTT "protocol". This isn't really hard and I managed to get that working. Here is a short sample of code demonstrating how I send some environmental data ...