Search found 51 matches

by dps
Fri Dec 06, 2019 10:59 pm
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 6944

Re: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)

So while the source of a particular venv is activated, i can move around the system and still use the commands, because when i activated that venv it added the /bin to my path (in addition to other variables). After deactivating the venv, my $PATH will return to normal, and all things that i changed...
by dps
Fri Dec 06, 2019 10:38 pm
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 6944

Re: Issues running on ESP8266MOD(NODEMCU board)

it works! Nice! thank you man! So, i guess the solution (for anyone looking for it) is to erase the flash first, and then upload. If youre having trouble erasing your flash, try updating your esptool to a newer version!

Ciao!
by dps
Fri Dec 06, 2019 10:35 pm
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 6944

Re: Issues running on ESP8266MOD(NODEMCU board)

Hey! check it out! erasing the flash worked! so i guess the idea for me is, ill just use this env for uPython, and create others as need when i learn more about python in general. now, lets see if the firmware being upload with this new (2.8) version of esptool. brb
by dps
Fri Dec 06, 2019 10:31 pm
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 6944

Re: Issues running on ESP8266MOD(NODEMCU board)

alright just did it, with 3.6. created a test env and activated it. so if i install esptool.py here, would i always have to be in this directory to use it, and with the env activated?
by dps
Fri Dec 06, 2019 10:14 pm
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 6944

Re: Issues running on ESP8266MOD(NODEMCU board)

when installing something on Linux with pip or pip3, which should i use and should i use the --user flag, and would that solve the package conflicts? or should i try to figure out how to setup a virtual env of some kind, and install this all in that?
by dps
Fri Dec 06, 2019 10:12 pm
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 6944

Re: Issues running on ESP8266MOD(NODEMCU board)

hmm, ill try. I havent learned how to use Python on Linux yet, and when ive tried to use it i guess i was using packages that conflicted with each other and.... yeah, it was all messed up. so I ended up just using the esptool that is packaged in the standard Ubuntu repos. Ill see if i can get a back...
by dps
Fri Dec 06, 2019 9:24 pm
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 6944

Re: Issues running on ESP8266MOD(NODEMCU board)

Although, it does say that it erases the flash when I upload firmware to it. Also, I tried the different flash mode params (dio,dout,qio,qout, etc), and using them hasnt made it work. is there something else that i am missing here?
by dps
Fri Dec 06, 2019 9:11 pm
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 6944

Re: Issues running on ESP8266MOD(NODEMCU board)

hmm, whenever i try to erase the flash, it tells me that its not supported. Here is the output: ┌─[✗]─[dps@silversurfer]─[~] └──╼ $esptool --port /dev/ttyUSB0 erase_flash esptool.py v2.1 Connecting.... Detecting chip type... ESP8266 Chip is ESP8266 Enabling default SPI flash mode... Erasing flash (t...
by dps
Thu Dec 05, 2019 3:03 am
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 6944

Re: Issues running on ESP8266MOD(NODEMCU board)

What i really just am not getting, is why i can keep uploading to the one board, and it works flawlessly. Just not with the other two. do you think that there is some minor variation between them? They all came in a set, and they were allegedly the same. Is there any kind of way to do some sort of.....
by dps
Thu Dec 05, 2019 2:55 am
Forum: ESP8266 boards
Topic: [SOLVED]Issues running on ESP8266MOD(NODEMCU board)
Replies: 33
Views: 6944

Re: Issues running on ESP8266MOD(NODEMCU board)

I do want to note though, that I was able to upload and run uPython on 1 out of 3 of these boards, successfully. Two of them though, are still doing the original stuff.