WiPy crashes

Questions and discussion about The WiPy 1.0 board and CC3200 boards.
Target audience: Users with a WiPy 1.0 or CC3200 board.
Post Reply
rockybulwinkle
Posts: 2
Joined: Fri Oct 28, 2016 6:09 pm

WiPy crashes

Post by rockybulwinkle » Fri Oct 28, 2016 6:26 pm

Hello all,

This is my first time posting here. I recently got the new WiPy 2.0 board. I am running firmware "wipy_0.9.2.b2.bin". os.uname returns:
(sysname='ESP32', nodename='ESP32', release='0.9.0b', version='1f7bdfd on 2016-10-09', machine='WiPy with ESP32')

I wrote a mandelbrot generator a while ago. I've tested it on both a pyboard as well as CPython 3.5.1, and both work as expected.

However, on my WiPy 2.0, it crashes. It spews out the following message: http://pastebin.com/Q9UucK7y

The code that causes the issue: http://pastebin.com/0ytEJ9zS

It seems that just running within_mandelbrot(0, 0, 10) a couple thousand times causes the error. Has anybody seen this kind of crash before? Should I create a bug report? Where would that even go?

I have narrowed it down to the within_mandelbrot function via print statements. It doesn't seem like a garbage collection issue because I saw it crash one time with 140k left.

Any input is appreciated.

Lysenko
Posts: 62
Joined: Wed Aug 17, 2016 1:21 pm

Re: WiPy crashes

Post by Lysenko » Fri Oct 28, 2016 9:56 pm

rockybulwinkle wrote:Hello all,
This is my first time posting here. I recently got the new WiPy 2.0 board. I am running firmware "wipy_0.9.2.b2.bin". os.uname returns:
(sysname='ESP32', nodename='ESP32', release='0.9.0b', version='1f7bdfd on 2016-10-09', machine='WiPy with ESP32')
That's coming from the the ESP32/FreeRTOS that underlies the WiPy board. To diagnose that sort of thing you really need GDB and/or a JTAG debugger and the ability to rebuild the MicroPython interpreter from source code.

You could try deactivating WiFi and see if that makes any difference, but if it does then it isn't any sort of fix it just points the finger (vaguely) at a processor core affinity bug that may still be present in your firmware.

User avatar
pythoncoder
Posts: 4037
Joined: Fri Jul 18, 2014 8:01 am
Location: UK
Contact:

Re: WiPy crashes

Post by pythoncoder » Sat Oct 29, 2016 7:00 am

You need to go to Pycom's forum for official support for WiPy 2.0 https://forum.pycom.io/.
Peter Hinch

rockybulwinkle
Posts: 2
Joined: Fri Oct 28, 2016 6:09 pm

Re: WiPy crashes

Post by rockybulwinkle » Sun Oct 30, 2016 3:16 pm

Thank you for the replies.

I figured out that I had to update the firmware. I thought I had by uploading the .bin into /flash/sys but it doesn't seem to work like that for the WiPy 2.0.

Since I didn't have the carrier board, I held an arduino in reset by tying the reset pin to ground and wiring its tx and rx pins to the uart0 of the board.

I also had to set the firmware update tool to run at 115200 baud because my arduino didn't support higher than that.

Anyway, after updating the firmware my program ran as expected.

Thanks again,
Chris

Post Reply