Porting to STM32L476Discovery/LimiFrog

Discussion and questions about boards that can run MicroPython but don't have a dedicated forum.
Target audience: Everyone interested in running MicroPython on other hardware.
User avatar
badi
Posts: 50
Joined: Mon Aug 10, 2015 2:18 pm
Location: Bern, Switzerland

Re: Porting to STM32L476Discovery/LimiFrog

Post by badi » Wed Mar 02, 2016 10:48 am

CDC and MSC is working
- REPL is working now.
- The kit appears as USB memory stick on my PC and the Flash memory is persistent.

DMA on DAC must be resolved and therfore the repo does not compile on other platforms using DAC.
badi

User avatar
badi
Posts: 50
Joined: Mon Aug 10, 2015 2:18 pm
Location: Bern, Switzerland

Re: Porting to STM32L476Discovery/LimiFrog

Post by badi » Thu Mar 03, 2016 8:11 am

Compiles with working DAC on all STM build targets even my audio shield for pyboard V1.0 works.

After some tests I'll try to push it to main repo.
badi

User avatar
jgriessen
Posts: 191
Joined: Mon Sep 29, 2014 4:20 pm
Contact:

Re: Porting to STM32L476Discovery/LimiFrog

Post by jgriessen » Fri Mar 04, 2016 12:58 am

Congrats on getting your port debugged!
John Griessen blog.kitmatic.com

photoacoustic
Posts: 24
Joined: Mon Apr 27, 2015 8:25 am

Re: Porting to STM32L476Discovery/LimiFrog

Post by photoacoustic » Fri Mar 04, 2016 11:19 pm

Thanks for the great work

User avatar
badi
Posts: 50
Joined: Mon Aug 10, 2015 2:18 pm
Location: Bern, Switzerland

Re: Porting to STM32L476Discovery/LimiFrog

Post by badi » Sat Mar 05, 2016 7:59 am

It is a little bit early .. first I have to get it into the main repo and there are some changes which are quite big.

BTW I am still hunting bugs...
badi

User avatar
badi
Posts: 50
Joined: Mon Aug 10, 2015 2:18 pm
Location: Bern, Switzerland

Re: Porting to STM32L476Discovery/LimiFrog

Post by badi » Tue Mar 08, 2016 10:23 pm

I hope I just squashed the last bug .. but someone said the last bug is never found ;-( ...
badi

User avatar
badi
Posts: 50
Joined: Mon Aug 10, 2015 2:18 pm
Location: Bern, Switzerland

Re: Porting to STM32L476Discovery/LimiFrog

Post by badi » Wed Mar 23, 2016 10:09 pm

I just entered the last PR in a series (#1888, #1890, #1903, #1904, #1916, #1917, #1918, #1919, #1920, #1921, #1922, #1924, #1925, #1937) to support stm32l476Disco
badi

User avatar
badi
Posts: 50
Joined: Mon Aug 10, 2015 2:18 pm
Location: Bern, Switzerland

Re: Porting to STM32L476Discovery/LimiFrog

Post by badi » Wed Mar 30, 2016 8:01 am

I added basic support for building LIMIFROG and deploy over stlinkk to my repo at

https://github.com/tobbad/micropython/t ... ntegration

If you have a STLINK at hand (is on any discovery board) you can deploy the binary with:
`make BOARD=LIMIFROG deploy2b`
I need this special target (defined in `mpconfigboard.mk`) as the flash on LimiFrog is just 512 so the `.text` area (this is were firmware1.bin has to be stored) starts @ 0x080008800.
badi

User avatar
marfis
Posts: 192
Joined: Fri Oct 31, 2014 10:29 am
Location: Zurich / Switzerland

Re: Porting to STM32L476Discovery/LimiFrog

Post by marfis » Thu Mar 31, 2016 9:31 pm

Did you manage to support the internal OpAmps as well?

User avatar
badi
Posts: 50
Joined: Mon Aug 10, 2015 2:18 pm
Location: Bern, Switzerland

Re: Porting to STM32L476Discovery/LimiFrog

Post by badi » Fri Apr 01, 2016 1:54 pm

It was not the aim of this series of PR to support all feature on this new L4 series - so I kept the changes to micropython stmhal code to an absolute minimum. In my opinion further extension can later be added. I think these PRs should be a door opener for others to contribute code.
badi

Post Reply