[STM32F407VGT6] Board HELP!

Discussion and questions about boards that can run MicroPython but don't have a dedicated forum.
Target audience: Everyone interested in running MicroPython on other hardware.
User avatar
japuzzo
Posts: 1
Joined: Wed Apr 25, 2018 2:51 am

[STM32F407VGT6] Board HELP!

Post by japuzzo » Fri Jun 08, 2018 12:51 am

Just got this board listed as a DYIMORE board, which is of the CJMCU-407 design.
I've tried a few diffrent version, but no luck after flashing the serial port does not become active.

Front: https://i.stack.imgur.com/9Fu73.jpg
Back: https://s3-ap-southeast-1.amazonaws.com ... 062512.jpg

Anyone know of this board and how to get MicroPython working on it?

vbolshakov
Posts: 8
Joined: Sun Aug 25, 2019 8:50 am

Re: [STM32F407VGT6] Board HELP!

Post by vbolshakov » Thu Sep 05, 2019 12:04 pm

You need to build custom FW for this boars, as there is no MICROPY_HW_USB_VBUS_DETECT_PIN (pin_A9)and MICROPY_HW_USB_OTG_ID_PIN (pin_A10)

User avatar
mcauser
Posts: 490
Joined: Mon Jun 15, 2015 8:03 am

Re: [STM32F407VGT6] Board HELP!

Post by mcauser » Fri Sep 06, 2019 5:02 am

I don't have one of these VGT6 boards.

I do have a few VET6 ones. This might be a good starting point for creating your own board def:
https://github.com/mcauser/BLACK_F407VE

The VE has 512 Kbytes and the VG has 1 Mbyte flash.
Other than that, pretty similar.
See if you can grab a schematics pdf from the vendor so you can map the pins in your mpconfigboard.h and pins.csv

vbolshakov
Posts: 8
Joined: Sun Aug 25, 2019 8:50 am

Re: [STM32F407VGT6] Board HELP!

Post by vbolshakov » Fri Sep 06, 2019 10:42 am

My mpconfigboard.h for this board https://pastebin.com/A6J2XcLb

wasp09
Posts: 4
Joined: Tue Nov 17, 2020 10:33 pm

Re: [STM32F407VGT6] Board HELP!

Post by wasp09 » Tue Nov 17, 2020 10:56 pm

I have a DIYMORE VET6, basic and it works with micropython. Had to select bootloader and run mode by straps.

I bought a new one, half year ago and arrived today, with a SD card slot. The board does not have any brandname marking.
https://ae01.alicdn.com/kf/Haca172ca6af ... 0fb00s.jpg

It's a STM32F407VGT7 with 8MHz and 32.768KHz crystals. Currently it works a micro card reader. :(

USB comes up as ID 0483:5720 STMicroelectronics Mass Storage Device, not a tty port. Don't really know what FW is on it.

Can anyone help me to find the definition and procedure for getting MicroPython on it.

Thanks.

wasp09
Posts: 4
Joined: Tue Nov 17, 2020 10:33 pm

Re: [STM32F407VGT6] Board HELP!

Post by wasp09 » Tue Nov 17, 2020 11:36 pm

I think my board is this one:

https://stm32-base.org/boards/STM32F407VET6-STM32F4XX-M

with VGT6 instead of VET6

User avatar
jimmo
Posts: 2232
Joined: Tue Aug 08, 2017 1:57 am
Location: Sydney, Australia
Contact:

Re: [STM32F407VGT6] Board HELP!

Post by jimmo » Wed Nov 18, 2020 2:48 am

wasp09 wrote:
Tue Nov 17, 2020 10:56 pm
USB comes up as ID 0483:5720 STMicroelectronics Mass Storage Device, not a tty port. Don't really know what FW is on it.
If it's the board you linked to then the process is to get it into the ST Bootloader (short the BOOT0 pin to Vcc before powering the board), then you can use a DFU programing tool (e.g. dfu-util or dfuse) to flash the .dfu file for that board.

User avatar
mcauser
Posts: 490
Joined: Mon Jun 15, 2015 8:03 am

Re: [STM32F407VGT6] Board HELP!

Post by mcauser » Wed Nov 18, 2020 3:29 am

@wasp09 the board shown in that link above is a "DevEBox" from "MCUDev" in China.
They normally sell them on mcudev.taobao.com, however some other shops on AliExpress are reselling them.
If you look close in the top right corner on the back of the board, it says "mcudev.taobao.com".

The same devs that made the popular "Black" VET6, VGT6, ZGT6 boards, although, they forgot to put their company name on the boards.
They just went with "STM32F4XX".
When you dig around on pan.baidu.com and view the schematics and docs for the boards, it shows their name "MCUDev".

I made a bunch of defs for these boards:
https://github.com/mcauser/BLACK_F407VE
https://github.com/mcauser/BLACK_F407ZE
https://github.com/mcauser/BLACK_F407ZG
https://github.com/mcauser/MCUDEV_DEVEBOX_F407VET6
https://github.com/mcauser/MCUDEV_DEVEBOX_F407VGT6
https://github.com/mcauser/MCUDEV_DEVEBOX_H7XX_M

I only actually own the BLACK_F407VE and BLACK_F407ZG boards. My DevEBox got lost in the mail and I got a refund. The rest I coded from the documentation. They're all pretty similar.

wasp09
Posts: 4
Joined: Tue Nov 17, 2020 10:33 pm

Re: [STM32F407VGT6] Board HELP!

Post by wasp09 » Wed Nov 18, 2020 3:01 pm

Mine is different from the pictures posted. It has no brandname marking anywhere. It is a clone of a clone from aliexpress.

I did put micropython on it last night using MCUDEV_DEVEBOX_F407VGT6. That had SD and winbond turned off. Hence I lost my SD reader function, not worthing the extra $ over my DIYMORE. The 2 files on /flash also seemed corrupted and README is missing.

I decided to turn both on even though the schema shows the SD detection is not connected. Then we have clean files on /flash and I get my SD card reader function back with micropython installed. :) :)

Without SD detection we have to power cycle the board for /sd to show up. That is OK for now.

When I have time I would check if SD detection is really not connected, I guess we can jumper it to an IO pin if we want. Just don't want to short circuit two IO pins if SD detect really is connected to one already.

Thanks.
+++++++

Looks like the 9th pin and the metal case of the SD are not connected. We can pick an IO pin and connect the case to GND to add SD detection if we want.
Last edited by wasp09 on Sat Nov 28, 2020 12:12 am, edited 2 times in total.

wasp09
Posts: 4
Joined: Tue Nov 17, 2020 10:33 pm

Re: [STM32F407VGT6] Board HELP!

Post by wasp09 » Wed Nov 18, 2020 3:04 pm

BTW, the marking of BOOT0 on my board is BY0 on the front and BT0 on the back. :)

Post Reply