bare metal Raspberry Pi Zero port

Discussion and questions about boards that can run MicroPython but don't have a dedicated forum.
Target audience: Everyone interested in running MicroPython on other hardware.
User avatar
boochow
Posts: 28
Joined: Sat Dec 16, 2017 9:36 am

Re: bare metal Raspberry Pi Zero port

Post by boochow » Sat Dec 07, 2019 11:31 pm

Since I have been adding no code to my repo this year, the code you see on the github is the latest one.

Trekintosh
Posts: 5
Joined: Fri Dec 06, 2019 7:10 pm

Re: bare metal Raspberry Pi Zero port

Post by Trekintosh » Sat Dec 14, 2019 7:50 pm

How difficult would it be to bring the code up to the current version of MicroPython?

User avatar
boochow
Posts: 28
Joined: Sat Dec 16, 2017 9:36 am

Re: bare metal Raspberry Pi Zero port

Post by boochow » Sun Dec 15, 2019 4:11 am

How difficult would it be to bring the code up to the current version of MicroPython?
No difficulties.
I just have updated the repository and now it can be built with MicroPython v1.11.

ZuluSpl0it
Posts: 2
Joined: Mon May 04, 2020 3:58 pm

Re: bare metal Raspberry Pi Zero port

Post by ZuluSpl0it » Mon May 04, 2020 5:11 pm

I've updated to MicroPython 1.12 on my fork:
https://github.com/ZuluSpl0it/micropython-raspberrypi
and I've put in a pull request to get it on the parent repo.

I was trying to enable the Native emitter by changing the options in mpconfigport.h. I've tried

#define MICROPY_EMIT_THUMB (1)
and
#define MICROPY_EMIT_ARM (1)

the @micropython.native decorator is now recognized, but the raspi Zero W hangs.

While running a performance test (just incrementing a variable in a loop for 1 second and then reporting the total):

On a ESP8266 I get:
No Optimization Count: 30278
Just preloading class Count: 45119
Native emitter only Count: 45440
Preload class plus Native emitter Count: 81750


On the raspi Zero W I get:
No Optimization Count: 43886
Just preloading class Count: 71338
then it just hangs for the function with the @micropython.native decorator

Any ideas on what I can try? Or am I enabling the wrong options?

PH1LJ
Posts: 1
Joined: Thu May 07, 2020 4:31 pm

Re: bare metal Raspberry Pi Zero port

Post by PH1LJ » Thu May 07, 2020 4:44 pm

can you please help

I'm trying to create a bare-metal usd card for my Pi zero, I'm pretty sure I created the usd card as per the detail
but all I see is the rainbow screen on the pi.

Just to confirm - all I have on the USD is shown below :-

build folder with firmware.img
bootcode.bin
config.txt
start.elf

Any ideas

ZuluSpl0it
Posts: 2
Joined: Mon May 04, 2020 3:58 pm

Re: bare metal Raspberry Pi Zero port

Post by ZuluSpl0it » Fri May 08, 2020 1:08 pm

Are you able to connect via the REPL? Did you use the main repo or a fork to build?

Post Reply