Build for NUCLEO_F411RE fails

Discussion and questions about boards that can run MicroPython but don't have a dedicated forum.
Target audience: Everyone interested in running MicroPython on other hardware.
Post Reply
Kenjutsu
Posts: 2
Joined: Fri Jun 21, 2019 5:52 am

Build for NUCLEO_F411RE fails

Post by Kenjutsu » Fri Jun 21, 2019 6:01 am

Hello everyone,

I am trying to build MicroPython for my NUCLEO_F411RE board. I downloaded the latest master from github and proceded as follows:

1. unzip micropython-master.zip
2. cd mpy-cross
3. make
4. git submodule update --init

I then get the error: fatal: not a git repository (or any of the parent directories): .git

I'm using macOS 10.13.6

Any help will be greatly appreciated ;)

User avatar
jimmo
Posts: 427
Joined: Tue Aug 08, 2017 1:57 am
Location: Sydney, Australia

Re: Build for NUCLEO_F411RE fails

Post by jimmo » Fri Jun 21, 2019 6:17 am

You'll need to check out the git repository. Rather than using a zip download, try git cloning git@github.com:micropython/micropython.git instead.

Kenjutsu
Posts: 2
Joined: Fri Jun 21, 2019 5:52 am

Re: Build for NUCLEO_F411RE fails

Post by Kenjutsu » Sun Jun 23, 2019 3:22 pm

Thank you, that did it ;)

I did a: git clone https://github.com/micropython/micropython.git

Followed by: make -C mpy-cross

Then: make BOARD=NUCLEO_F411RE deploy-stlink

however, I ran into the same problem described here: https://github.com/micropython/micropython/issues/4455 mpy-cross broken on macOS Mojave #4455

For me, the trick was to: brew uninstall binutils

Now, make BOARD=NUCLEO_F411RE deploy-stlink works 8-)

Post Reply