Page 1 of 1

Trying to add ethernet support to STM32F407VE

Posted: Wed Nov 06, 2019 10:50 pm
by untitled
Things I have done:
  • defined MICROPY_HW_ETH_* variables in mpconfigboard.h
  • added MICROPY_PY_LWIP = 1 to mpconfigboard.mk
  • added ETH_* pins to pins.csv
  • added additional pins from Port F, G, H, I to pins.csv
Here is my modified board: https://github.com/untitledlt/BLACK_F407VE

Now when I'm trying to build it, i get:

Code: Select all

In file included from eth.c:31:
eth.c: In function 'eth_mac_init':
eth.c:163:106: error: implicit declaration of function 'STATIC_AF_ETH_RMII_REF_CLK'; did you mean 'STATIC_AF_ETH_RMII__REF_CLK'? [-Werror=implicit-function-declaration]
     mp_hal_pin_config_alt_static(MICROPY_HW_ETH_RMII_REF_CLK, MP_HAL_PIN_MODE_ALT, MP_HAL_PIN_PULL_NONE, STATIC_AF_ETH_RMII_REF_CLK);
                                                                                                          ^~~~~~~~~~~~~~~~~~~~~~~~~~
pin_static_af.h:42:48: note: in definition of macro 'mp_hal_pin_config_alt_static'
         mp_hal_pin_config(pin_obj, mode, pull, fn_type(pin_obj)) /* Overflow Error => alt func not found */
                                                ^~~~~~~
cc1: all warnings being treated as errors
make: *** [build-BLACK_F407VE/eth.o] Error 1

What am I doing wrong here?

Re: Trying to add ethernet support to STM32F407VE

Posted: Thu Nov 07, 2019 1:18 pm
by DJShadow1966
Hello

The is an error in the CSV file I need to find the right on.

Regards Mike

Re: Trying to add ethernet support to STM32F407VE

Posted: Thu Nov 07, 2019 1:31 pm
by DJShadow1966
Hello
Found it there is an error in the file stm32f407_af.csv, on line four it has the following :-

ETH_MII_RX_CLK/ETH_RMII__REF_CLK

The fault is between the RMII and REF there are two _ when in fact there should be only one i.e. ETH_MII_RX_CLK/ETH_RMII_REF_CLK .
That will fix the issue

Regards Mike

Re: Trying to add ethernet support to STM32F407VE

Posted: Fri Nov 08, 2019 9:19 am
by untitled
Thanks Mike!
Never thought it could be so simple :)

Feel free to collect your +50 bounty on https://stackoverflow.com/questions/586 ... -for-stm32

Re: Trying to add ethernet support to STM32F407VE

Posted: Fri Nov 08, 2019 12:57 pm
by DJShadow1966
Hello

Lucky for you I found it took my a few days to find it myself, was tearing what hair I have out.

Mike