Page 2 of 2

Re: bme680 adafruit on pyboard

Posted: Tue Jun 30, 2020 10:21 am
by Roberthh
Github was broken yesterday afternoon. Now it seems to work again. The humidity sensor of the BME680 seems a little bit off. I made once a test series with various sensors in controlled humidity environments (Box with saturated solutions of various chemicals).The results are below. Green=within spec, Yellow=marginal, white=outside spec. The "University" column are the values form a close university weather station, which I took at a low wind weather condition. Pressure and temperature matched well with the "university" readings.
test results.jpg
test results.jpg (127.5 KiB) Viewed 425 times
For re-conditioning I followed the procedure in the data sheet. What i have observed that after re-conditioning simple letting the sensor rest for 10-20 days will bring it to an reasonable error.

Re: bme680 adafruit on pyboard

Posted: Tue Jun 30, 2020 10:39 am
by IHOXOHI
Nice. Thanks Roberthh for this perfect job.

There is only one difference in the bme.gaz value construction between this lib and the adafruit-lib...

In the adafruit : "self._last_reading = time.monotonic()"

In this lib : "self._last_reading = time.ticks_ms()"

The value of bme.gas stay the same so maybe, the problem comes from this change...

Re: bme680 adafruit on pyboard

Posted: Tue Jun 30, 2020 10:58 am
by IHOXOHI
Sorry Roberthh,

I have tested until now with the bme680 from seeed... Until now, I have never seen difference between the bme680 from seed and the bme680 from adafruit. But Now, I have tested, and the g.gas works with the bme680 from adafruit... Others values are the same.

The bme.altitude works too.

Thanks for all.

Have a fun.

Re: bme680 adafruit on pyboard

Posted: Tue Jun 30, 2020 6:48 pm
by Roberthh
The driver now supports SPI.