Page 2 of 2

Re: apa102 lib for esp32

Posted: Fri May 15, 2020 11:20 pm
by barbsbou
OutoftheBOTS_ wrote:
Fri May 15, 2020 8:22 pm
If your only going to be running 10 LEDs you can probably run them from the ESP32 5v pin but wouldn't run larger amounts (Ardunio power supply isn't any better than ESP32).

Do you also have a common ground to both the power supply and the ESP32???
Thank you for your reply
I didn't find any 5V output of the esp32, I guess that you mean I could use the 3,3V output of esp32?

I did not link the GND of the esp32 with the arduino one, I tested it and nothing change.
I tested the apa102 led stripe with fastled on arduino and, I did not have that I wanted, but the led swith on, whereas that with esp32 and micropython_dotstar all led stay off...

I am sure that the problem is the interface between chair and keyboard, but I don't know where I missed :oops:

Re: apa102 lib for esp32

Posted: Sat May 16, 2020 5:15 am
by OutoftheBOTS_
The LEDs will need 5v supply to run.

You ESP32 board should havea 5v supply from the USB input.

Is this your board??
Capture.JPG
Capture.JPG (117.25 KiB) Viewed 390 times

Re: apa102 lib for esp32

Posted: Sat May 16, 2020 9:10 am
by barbsbou
OutoftheBOTS_ wrote:
Sat May 16, 2020 5:15 am
The LEDs will need 5v supply to run.

You ESP32 board should havea 5v supply from the USB input.

Is this your board??
Capture.JPG
Sure you are right, this is mine. Ok Thank you the
Clearly my connections are simpler thank you...but nothing change obviously.
I really don't see what I am doing wrong...

Re: apa102 lib for esp32

Posted: Sat May 16, 2020 8:04 pm
by OutoftheBOTS_
@Mattyt usually thoroughly tests his libraries before making them pubic and his demo code is very simple to use so I assume either your APA102 are damaged and not working correctly or your connections are incorrect.

Re: apa102 lib for esp32

Posted: Tue May 26, 2020 9:23 pm
by barbsbou
OutoftheBOTS_ wrote:
Sat May 16, 2020 8:04 pm
@Mattyt usually thoroughly tests his libraries before making them pubic and his demo code is very simple to use so I assume either your APA102 are damaged and not working correctly or your connections are incorrect.
I am sure, I finally test the connection with volmeter to understand that I had a connection problem with my gnd....
Uff now it is working!!!

Than you a lot for your help

Re: apa102 lib for esp32

Posted: Wed May 27, 2020 12:36 am
by mattyt
Just glad to hear it's working! :)