Repl not Responding

All ESP8266 boards running MicroPython.
Official boards are the Adafruit Huzzah and Feather boards.
Target audience: MicroPython users with an ESP8266 board.
Post Reply
andrea
Posts: 1
Joined: Mon Jun 11, 2018 3:33 pm

Repl not Responding

Post by andrea » Mon Jun 11, 2018 4:09 pm

Hello,
I had some Problems when I tried to flash Micropython on my board (NodeMCU Lua Amica V2).
This seems to be happening often, but I still didn't find any post helping me.
I erased the flash and rewrote it without any Problems. I pressed the RST pin and tried to start a REPL to enter Code, but it wasn't working at all. First I tried Picocom then Minicom, they both didn't let me type anything into the REPL, also they don't show ">>>" at the beginning as they did when I was using the repl on the pyboard.
Then I tried to use RShell and entered the repl. I was able to type this time but still no ">>>" and no response from the board.
I tried to connect from a Laptop with Antergos Linux installed and from my Raspberry with Raspian.
I also tried various builts of Micropython (including the 512 version, even though flash_id tells me he has 4MB)

I hope someone has any idea, what could have went wrong :/

User avatar
pythoncoder
Posts: 2642
Joined: Fri Jul 18, 2014 8:01 am
Location: UK
Contact:

Re: Repl not Responding

Post by pythoncoder » Wed Jun 13, 2018 7:25 am

As far as I'm concerned rshell is the gold standard for communications with MicroPython targets: if it doesn't work, the target is at fault.

So I suspect your esptool invocation doesn't match your hardware. Have you tried the -fm dio option as recommended in the docs? How current is your esptool.py? Mine is v2.1-beta1.

I suggest you post your esptool invocation line. There is a -verify_flash option which should provide some feedback on success or failure. I use

Code: Select all

esptool.py --port /dev/ttyUSB0 --baud 115200 write_flash --verify --flash_size=detect -fm dio 0 build/firmware-combined.bin
If you're using pre-built firmware you'll need to adapt the last part of the line to point to your firmware.bin file.
Peter Hinch

cefn
Posts: 192
Joined: Tue Aug 09, 2016 10:58 am

Re: Repl not Responding

Post by cefn » Wed Jun 13, 2018 8:27 pm

There's a reasonable chance that if you download install vgkits-vanguard ( https://pypi.org/project/vgkits-vanguard/ ) that you can simply run...

Code: Select all

vanguard brainwash micropython
vanguard shell
...and the first line will install 1.9.4 Micropython, and the second will launch a terminal.

Let me know how you get on.

Post Reply