8266EX Module with MicroPython in continous loop & REPL non responsive

All ESP8266 boards running MicroPython.
Official boards are the Adafruit Huzzah and Feather boards.
Target audience: MicroPython users with an ESP8266 board.
Post Reply
user-1
Posts: 2
Joined: Wed Mar 13, 2019 7:43 pm

8266EX Module with MicroPython in continous loop & REPL non responsive

Post by user-1 » Wed Mar 13, 2019 7:55 pm

Hi.

In case this question is a repeat then I am sorry but I am not able to get this thing fixed.

1. 8266EX Board with 1M Flash
2. Flashed & tried both latest stable & daily built esp8266-20190125-v1.10.bin and esp8266-20190313-v1.10-203-g68a5d6fe7.bin
3. After getting the Python prompt (see below), the micropython goes into an infinite loop, loading again and again. In between not taking any commands

4. I tried C-a & going into RAW mode, it does go if I press C-a continously but after 10 seconds it reloads the REPL shell again.
5. I tried with both minicom and picocom & the REPL just does not take in any command but keeps loading itself in infinite loop.


-------debug------ output on ttyUSB0 -b 115200


��c���OSError: [Errno 2] ENOENT
OSError: [Errno 2] ENOENT

MicroPython v1.10-8-g8b7039d7d on 2019-01-26; ESP module with ESP8266
Type "help()" for more information.
>>>
ets Jan 8 2013,rst cause:4, boot mode:(3,6)

wdt reset
load 0x40100000, len 31020, room 16
tail 12
chksum 0xd2
ho 0 tail 12 room 4
load 0x3ffe8000, len 1100, room 12
tail 0
chksum 0x9a
load 0x3ffe8450, len 824, room 8
tail 0
chksum 0xbd
csum 0xbd
����o��;��g|�
�d�prlc�
�|s�d�g�
�'�
d`��r�l�d�
l ��{�l�l�

d`��;�$
���
d$`sd��r$����bČb|$c���b|��Čldc��o��g'��lg�
��l��ld�
��l`�o�����c
d$섇cğ��#
d
�c;l{$s�'���
��g����cs#��b���OSError: [Errno 2] ENOENT
OSError: [Errno 2] ENOENT

MicroPython v1.10-8-g8b7039d7d on 2019-01-26; ESP module with ESP8266
Type "help()" for more information.
>>>

user-1
Posts: 2
Joined: Wed Mar 13, 2019 7:43 pm

Re: 8266EX Module with MicroPython in continous loop & REPL non responsive

Post by user-1 » Mon Mar 18, 2019 7:54 am

In addition.

- On a new NodeMCU 8266 4MB flash it works fine, but one of two times same restart wdt (may be watchdog) is seen, but at least I can work.

- The AT firm ware on the problem giving 8266 1MB board works quite ok, though I see often Fatal Exception Errors till I press reset again.
May be its a module issue but:
1. Flashing is perfect with verification of hash.
2. I am seeing this issue in 2 modules 8266 1M

Post Reply