importing issue

All ESP8266 boards running MicroPython.
Official boards are the Adafruit Huzzah and Feather boards.
Target audience: MicroPython users with an ESP8266 board.
Post Reply
Posts: 1
Joined: Fri May 14, 2021 1:54 pm

importing issue

Post by rambler_wf » Sat May 15, 2021 9:00 am

Hello Ladies/Gents, I tried importing, and got error as follow:

Code: Select all

Traceback (most recent call last):
             File "<stdin>", line 2, in <module>
             MemoryError: memory a

Code: Select all

import machine,time,network
import blynklib_mp as blynklib



I've coped the to ESP01(1M flash) board, is there anything wrong?

Thank you!

Posts: 3
Joined: Mon Feb 15, 2021 2:42 pm

Re: importing issue

Post by timmer » Wed Jun 09, 2021 11:13 am

I have a similar issue with the NodeMCU V3 (4MB). The system does not recognize the 'blynklib_mp' library, despite I placed it in a /lib folder on the NodeMCU.
I got earlier a the same memory error as you, but using and placing 'blynklib' in a /lib folder on the device solved that problem.
I use Thonny to interface.

Any idea why I get an unrecognized 'blynklib_mp' error ?

Post Reply