ESP01 Flashing Issue

All ESP8266 boards running MicroPython.
Official boards are the Adafruit Huzzah and Feather boards.
Target audience: MicroPython users with an ESP8266 board.
DougEE
Posts: 1
Joined: Sun Mar 12, 2017 2:24 am

ESP01 Flashing Issue

Postby DougEE » Sun Mar 12, 2017 2:30 am

Hello all, I'm new here, and new to MicroPython.

I've been attempting to get MicroPython flashed onto a ESP01, but I'm running into some issues. I'm attempting to flash the latest stable build (esp8266-20170108-v1.8.7.bin) but after flashing I'm left with no working REPL and no AP being broadcasted.

I'm flashing using the following commands:
$ esptool.py -p /dev/tty.usbserial-A104W2XT erase_flash
$ esptool.py -p /dev/tty.usbserial-A104W2XT --baud 115200 write_flash --flash_size=8m -fm dio 0 esp8266-20170108-v1.8.7.bin

I have also attempted omitting the '-fm dio', and flash baud >400000 with no success.

After flashing, but before power cycling the board, I see a continuous looping of this:
Fatal exception (28):
epc1=0x4000228b, epc2=0x00000000, epc3=0x00000000, excvaddr=0x000000b5, depc=0x00000000

And after power cycling I get a couple of lines of garbled text and it's unresponsive.

In researching I found this thread - https://forum.micropython.org/viewtopic.php?f=16&t=2419 - but the fix here was to use a 512KB flash compatible build (v1.8.bin), I've tried this version and a 512KB daily build but with no success.

Also, if I've read flashchips.h correctly, I am using a 1MB board:
$ esptool.py -p /dev/tty.usbserial-A104W2XT flash_id
esptool.py v1.3
Connecting....
Manufacturer: 51
Device: 4014

I investigated power related issues, by using two different breadboard power supplies (one of which claims it can deliver 700ma), then I tried using both in parallel, again no success. Also tried adding a couple of 100uF caps too.

Any ideas of what I'm doing wrong here?

shaoziyang
Posts: 134
Joined: Sun Apr 17, 2016 1:55 pm

Re: ESP01 Flashing Issue

Postby shaoziyang » Mon Mar 13, 2017 8:19 am

ESP-01 module has only 4Mbit flash (512KB), so flash_size will be set 4m.


Return to “ESP8266 boards”

Who is online

Users browsing this forum: Google [Bot] and 1 guest