Page 2 of 2

Re: Flashing the D1 Mini Lite

Posted: Fri May 19, 2017 12:38 am
by bandaangosta
Thanks for all the good info here.
I was facing a similar issue where I could correctly flash the firmware (thanks for the tip, deshipu), but could not load any python scripts onto boards Wemos D1 Mini Lite or D1 Mini v2.20. Meanwhile, the D1 Mini Pro worked fine. ampy would hang without any output.
At some point, trying to isolate involved variables, I tried the ampy script within a virtualenv environment. It worked!
Back to the global system libraries, it turned out that although ampy was up to date, one of its dependencies was not (but still satisfying ampy's requirement): pyserial. I had version 2.6 and updated to 3.3.
So, in summary, everything worked fine after running:

sudo pip install --upgrade pyserial

Re: Flashing the D1 Mini Lite

Posted: Thu Jun 22, 2017 2:51 am
by gregor
I have the same issue as reported by user "devnull" --port /dev/tty.wchusbserial1440 --baud 115200 write_flash --flash_mode=dout --flash_size=detect 0 esp8266-20170108-v1.8.7.bin

ampy --port /dev/tty.wchusbserial1440 put

results in

ampy.pyboard.PyboardError: could not enter raw repl

Is there an updated image available that does not include thsi error. THis is for D1 Mini

Re: Flashing the D1 Mini Lite

Posted: Thu Jun 22, 2017 6:54 pm
by Roberthh
If you open a serial terminal connection to the board, e.g. with screen, can you enter raw REPL mode manually with Ctrl-A?