Page 1 of 1

[Solved] Garbage from REPL prompt

Posted: Thu Aug 10, 2017 9:33 am
by richarddavison

I recently ordered a couple of Weeks D1 mini lite chips.

I previously managed to successfully flash micropython on another chip but accidentally fried it (high voltage hehe).

But this time around I only get garbage from screen command. Erase and flash is successful, all chips produce the same result in screen.

I flashed with the correct slower baud rate.

I read something that you should connect D3 to ground to put the ESP8266 in "flash mode" but not sure if this applies to devices with built in USB such as the D1 mini lite.

Thanks for any help!

Re: Garbage from REPL prompt

Posted: Fri Aug 11, 2017 5:28 pm
by deshipu
The D1 Mini Lite boards use an ESP8282 chip, not ESP8266, and those have a built-in flash memory of different type that the most commonly used memory on the ESP8266 boards. You need to set the flash type to dout for those boards, see: viewtopic.php?f=16&t=3217&p=19111

Re: Garbage from REPL prompt

Posted: Fri Sep 01, 2017 12:00 pm
by richarddavison
Solved it using:

Code: Select all

python3 /usr/local/lib/python3.6/site-packages/ -p /dev/tty.wchusbserial1440 --baud 115200 write_flash --flash_mode=dout --flash_size=detect 0 build/firmware-combined.bin