Can't enter text after connecting WebRepl

All ESP8266 boards running MicroPython.
Official boards are the Adafruit Huzzah and Feather boards.
Target audience: MicroPython users with an ESP8266 board.
Post Reply
guyd
Posts: 81
Joined: Fri Jul 20, 2018 6:08 am

Can't enter text after connecting WebRepl

Post by guyd » Tue Oct 09, 2018 4:31 pm

Hi,
I establish connection to wepRepl ( using password ) .
after successful connection - I can not enter any text. why is that ?
Last edited by guyd on Fri Oct 12, 2018 7:03 pm, edited 1 time in total.

adxx
Posts: 5
Joined: Mon Oct 08, 2018 6:45 pm

Re: Can't enter text after connecting WebRepl

Post by adxx » Thu Oct 11, 2018 11:49 am

Is there any code executed at that moment?

HermannSW
Posts: 144
Joined: Wed Nov 01, 2017 7:46 am
Contact:

Re: Can't enter text after connecting WebRepl

Post by HermannSW » Thu Oct 11, 2018 1:29 pm

adxx wrote:
Thu Oct 11, 2018 11:49 am
Is there any code executed at that moment?
That is good question, try pressing CTRL-C and you will stop eg. endless while loops.

adxx
Posts: 5
Joined: Mon Oct 08, 2018 6:45 pm

Re: Can't enter text after connecting WebRepl

Post by adxx » Thu Oct 11, 2018 2:03 pm

I need to run a check to reproduce my experience, but I recall similar behavior when I was testing pcd8544 with my ESP-12F - Ctrl-C did not help.
Will get back with the details on driver and the code.

UPD:
just double checked my code - WebREPL responds to Ctrl-C as it should be. Not sure why I got this impression that Ctrl-C did not work.

Post Reply