Curious if anyone else has run across this failure mode(responsive but wifi failed)

All ESP8266 boards running MicroPython.
Official boards are the Adafruit Huzzah and Feather boards.
Target audience: MicroPython users with an ESP8266 board.
Post Reply
rpi_nerd
Posts: 20
Joined: Sat Jul 29, 2017 2:05 pm

Curious if anyone else has run across this failure mode(responsive but wifi failed)

Post by rpi_nerd » Thu May 30, 2019 10:49 pm

Today I grabbed an ESP-12E I had lying around and flashed it the MicroPython firmware. Everything appeared to be going well until it came to setup wifi. No matter what, it simply wouldn't connect to my router. I tried two different firmware versions, same result. I decided to try it under the Arduino IDE, nothing. I flashed the MicroPython firmware again and this time left the AP mode on to see if any of my devices could see it. Didn't show up on anything.

At this point I'm thinking that it's either a failure within the chip or an iffy PCB trace. I'm tempted to try to take off the RF shield with a hot air gun and take a look.

User avatar
pythoncoder
Posts: 3695
Joined: Fri Jul 18, 2014 8:01 am
Location: UK
Contact:

Re: Curious if anyone else has run across this failure mode(responsive but wifi failed)

Post by pythoncoder » Fri May 31, 2019 10:01 am

I'd agree it sounds like a broken device. Has it ever worked? Have you tried a network scan?
Peter Hinch

rpi_nerd
Posts: 20
Joined: Sat Jul 29, 2017 2:05 pm

Re: Curious if anyone else has run across this failure mode(responsive but wifi failed)

Post by rpi_nerd » Fri May 31, 2019 12:21 pm

I did try network scan(using wlan.scan()) and it failed. It worked fine in the past.

Post Reply