Page 1 of 1

Wemos D1 mini webrepl

Posted: Sat Feb 22, 2020 7:50 am
by Vladimir Ota
I've set up webrepl om my Wemos D1 mini as in instructions. That worked exactly as described in instructions. However, when webrepl AP appears in my PC list of possible connections, I can't connect to it, because as soon as I enter the password set for this connection, I get error: "The network security key isn't correct."
Of course there's no way that I use wrong password.
If it is of any importance, I am working on Windows 10 pro x64 with all the updates and the MicroPython firmware is esp8266-20191220-v1.12.bin which I downloaded , on Feb, 21st, 2020.

Any help and/or suggestion will be appreciated.

Re: Wemos D1 mini webrepl

Posted: Sun Mar 08, 2020 4:35 am
by Kozure Okami
Wifi Network password is different than device setup password
For the wifi network is 'micropythoN' and for connecting within WebRepl is the password you setup on the device when setting up webRepl.

Re: Wemos D1 mini webrepl

Posted: Sun Mar 08, 2020 2:44 pm
by Vladimir Ota
Thanks for a reply. Unfortunately it does not solve my issue, as I was using the password which I set during webRepl set up. I used few other Wemos D1 boards, I downloaded microPython again and flash it to the boards, all with the same result.
Anyway, while webRepl would make my live a little bit easier

Re: Wemos D1 mini webrepl

Posted: Sun Mar 08, 2020 6:36 pm
by Kozure Okami
did you use 'micropythoN' password each time you tried to connect to the devices 'micro python-xxxxxx' wifi networks?
I am assuming firmware flashing and webrepl setup went well and were able to prompt the devices (putty).

I have flashed many D1 mini/pro and NodeMCU boards and if it managed to prompt in Putty and get the WebRepl setup Enable, password added and rebooted. Then they all could connect to their wifi network and then WebRepl terminal. I had a few duds that either only worked with arduino or nothing at all (NodeMcu were the worst).

Another thing i experienced was using Chrome was more stable. got dropped using explorer/safari or the micropython devices networks didn't show and needed multiple resets.

good luck!