rshell issues with an ESP32 Devkitv1 module

All ESP32 boards running MicroPython.
Target audience: MicroPython users with an ESP32 board.
Post Reply
Posts: 82
Joined: Sat Oct 27, 2018 5:17 pm

rshell issues with an ESP32 Devkitv1 module

Post by rpr » Sun Dec 02, 2018 6:47 pm

I'm having issues when rshell is used with a NodeMCU ESP32 board. It is a DEVKITV1. I have filed the following issue with the @dhylands rshell git repo.

Upon power up of the module, I can rshell into it once just fine. Subsequent attempts at connecting with rshell fail. It appears that upon exiting rshell the first time, it leaves the board in some hung state.The board however appears to remain connected at /dev/ttyUSB0. It needs another power cycle to make everything work again.

-- I have other TTGO ESP32 boards which function just fine.
-- I have tried different firmware versions including the 1.9.4 release, the most recent 1.9.4 development version, as well as the Loboris version. All have similar results.
-- I have tried using different computers to make the rshell connection. Similar results.
-- Have erased before flashing firmware.

Any suggestions? Thanks.

Post Reply