uPyCraft looses connection to ESP32

All ESP32 boards running MicroPython.
Target audience: MicroPython users with an ESP32 board.
Post Reply
ajocius
Posts: 43
Joined: Mon Feb 19, 2018 6:31 am

uPyCraft looses connection to ESP32

Post by ajocius » Tue Jan 01, 2019 3:37 pm

Hi, I have followed great tutorial to get short micropython code on ESP32 from here:
https://randomnerdtutorials.com/micropy ... 2-esp8266/

After trying and failing for a while I got it working finally. However, during that process I came several times to the situation where uPyCraft was not seeing or recognizing software on ESP32 and it was suggesting me to burn firmware. First i did it couple of times, then it works for a while and suddenly looses ESP32 again. It still sees COM port that ESP32 is connected to, PC also shows that specific COM PORT active.
Since that ESP32 is programmed to publish simple mqtt message every 5 sec, I can still see messages coming to mqtt broker. Meaning that ESP32 does what it is intended to do, so it has all files in tact.
I have thought usb cable is faulty. It can not be that it is just a power usb cable (without data) as I used same cable to program it. But I tried several cables anyway, same result. I have then thought that PC USB might not provide enough power to ensure communication, so I tried different USB on same PC. PC recognizes also I see COM port appear in uPyCraft, however, when I select it uPyCraft suggest me to burn firmware. I also tried external USB bridge with separate power supply, still the same.
So I got stuck a bit. Could that be that bitrate set in COM port settings might have something to do with it? I see that uPyCraft under Tools, Preferences, Serial baud is set by default on 115 200 ( I ceckon that is bits per second), while PC COM port settings has 9 600 bits per second.
Any thoughts?
I have then tried uPyLoader IDE and that connects successfully and sees/opens files inside ESP32. So it must be something wrong with uPyCraft settings I guess. I prefer uPyCraft due to its editor, that looks better than uPyLoader.

NilsBe
Posts: 1
Joined: Sun Jan 06, 2019 10:47 pm

Re: uPyCraft looses connection to ESP32

Post by NilsBe » Mon Jan 07, 2019 11:23 am

I have the same issue here. It's definitely not a cable problem.

A_plan
Posts: 1
Joined: Sun Feb 10, 2019 8:21 pm

Re: uPyCraft looses connection to ESP32

Post by A_plan » Sun Feb 10, 2019 8:26 pm

I have the same problem (WIN10, uPyCraft 1.1)

wangshujun@tom.com
Posts: 2
Joined: Fri Feb 15, 2019 9:22 am

Re: uPyCraft looses connection to ESP32

Post by wangshujun@tom.com » Fri Feb 15, 2019 9:38 am

Yesterday I had the same problem. The solution was to rename boot.py in other software.

The reason for the problem is that the time from the start of the connection to reset the target board to the appearance of Python prompts exceeds the maximum waiting time of the software.

Post Reply