Trying to add ethernet support to STM32F407VE

All ESP32 boards running MicroPython.
Target audience: MicroPython users with an ESP32 board.
Post Reply
User avatar
untitled
Posts: 9
Joined: Sat Nov 02, 2019 1:44 pm

Trying to add ethernet support to STM32F407VE

Post by untitled » Mon Nov 04, 2019 1:04 pm

EDIT: posted in wrong subforum. This post can be deleted as there is a new one at viewtopic.php?f=12&t=7209
Not sure why, but i can not delete it.

Things I have done:
  • defined MICROPY_HW_ETH_* variables in mpconfigboard.h
  • added MICROPY_PY_LWIP = 1 to mpconfigboard.mk
  • added ETH_* pins to pins.csv
  • added additional pins from Port F, G, H, I to pins.csv
Here is my modified board: https://github.com/untitledlt/BLACK_F407VE

Now when I'm trying to build it, i get:

Code: Select all

In file included from eth.c:31:
eth.c: In function 'eth_mac_init':
eth.c:163:106: error: implicit declaration of function 'STATIC_AF_ETH_RMII_REF_CLK'; did you mean 'STATIC_AF_ETH_RMII__REF_CLK'? [-Werror=implicit-function-declaration]
     mp_hal_pin_config_alt_static(MICROPY_HW_ETH_RMII_REF_CLK, MP_HAL_PIN_MODE_ALT, MP_HAL_PIN_PULL_NONE, STATIC_AF_ETH_RMII_REF_CLK);
                                                                                                          ^~~~~~~~~~~~~~~~~~~~~~~~~~
pin_static_af.h:42:48: note: in definition of macro 'mp_hal_pin_config_alt_static'
         mp_hal_pin_config(pin_obj, mode, pull, fn_type(pin_obj)) /* Overflow Error => alt func not found */
                                                ^~~~~~~
cc1: all warnings being treated as errors
make: *** [build-BLACK_F407VE/eth.o] Error 1

What am I doing wrong here?

User avatar
jimmo
Posts: 1465
Joined: Tue Aug 08, 2017 1:57 am
Location: Sydney, Australia
Contact:

Re: Trying to add ethernet support to STM32F407VE

Post by jimmo » Mon Nov 11, 2019 12:33 pm

Update for anyone who finds this -- fixed in https://github.com/micropython/micropython/issues/5286

Post Reply