ESP32 Erase_Flash problem

All ESP32 boards running MicroPython.
Target audience: MicroPython users with an ESP32 board.
Post Reply
Posts: 1
Joined: Sat Nov 21, 2020 1:24 pm

ESP32 Erase_Flash problem

Post by guss » Sat Nov 21, 2020 2:07 pm

Hello, I am new to this forum. I have a problem with my ESP32 (Sparfunk Thing with 4MB ROM). I cannot program a I tried to erase its flash, since I do not trust the firmware in it. I try esptool erase_flash and this is what happens:

guus@debian-dell:~$ esptool erase_flash v2.8
Found 2 serial ports
Serial port /dev/ttyUSB0
Detecting chip type... ESP32
Chip is ESP32D0WDQ6 (revision 1)
Features: WiFi, BT, Dual Core, 240MHz, VRef calibration in efuse, Coding Scheme None
Crystal is 26MHz
MAC: .......................(I deleted the MAC address in this post)
Enabling default SPI flash mode...
Erasing flash (this may take a while)...

A fatal error occurred: ESP32 ROM does not support function erase_flash.

However I am able to flash firmware on the module, but working with it is impossible. I tried simple IDE like Thonny and upyCraft, but both do not make my ESP32 board work. The firmware I flashed in the module is esp32-idf3-20180511-v1.9.4.bin from the micropython website; I also tried an older version: esp32-idf3-20200902-v1.13.bin.
Does somebody know what is going on here? I saw some older posts in this forum; I tried to follow the solutions, but without succes.

Thank you,

User avatar
Posts: 2222
Joined: Sat May 09, 2015 4:13 pm
Location: Rhineland, Europe

Re: ESP32 Erase_Flash problem

Post by Roberthh » Sat Nov 21, 2020 3:45 pm

Are you sure that you connected your module to /dev/ttyUSB0? There seem to eb two serial devices connected, since esptool finds two serial ports. It is more safe to specify the port name in the call of esptool with the option -p <port>

Post Reply