BLE doesn't work on APPinventor?

All ESP32 boards running MicroPython.
Target audience: MicroPython users with an ESP32 board.
Post Reply
julien
Posts: 11
Joined: Fri Mar 27, 2020 10:16 pm

BLE doesn't work on APPinventor?

Post by julien » Wed Dec 23, 2020 10:51 am

Hello,

I try to use the bluetooth Module with Appinventor BLE, but it doesn't works?
I try to use this module with NRFconnect and it works perfectly.
Here is my program BLE micropython: http://icnisnlycee.free.fr/images/SNT/o ... e_esp32.py
You can use program here. They works perfectly with NRFconnect, but doesn't work with appinventor.
https://github.com/micropython/micropyt ... /bluetooth

I used this library: https://docs.micropython.org/en/latest/ ... etooth.BLE
So there is somethong special in Appiventor extension here
http://iot.appinventor.mit.edu/#/blueto ... othleintro

Here the program in appiventor.
http://icnisnlycee.free.fr/images/SNT/o ... evice2.aia

or there is something special in the module ubluetooth?
Thanks to help me please.
Julien

User avatar
jimmo
Posts: 2059
Joined: Tue Aug 08, 2017 1:57 am
Location: Sydney, Australia
Contact:

Re: BLE doesn't work on APPinventor?

Post by jimmo » Mon Jan 11, 2021 12:04 am

julien wrote:
Wed Dec 23, 2020 10:51 am
I try to use the bluetooth Module with Appinventor BLE, but it doesn't works?
I saw someone (maybe you?) sent a PR showing an Appinventor example -- https://github.com/micropython/micropython/pull/6735 -- Does that give any hints?

I can't seem to load your code from that URL.

The ubluetooth module just provides a really low level GATT implementation. If your program is working from nRF Connect then it's suprising that it doesn't work from App inventor? Do they require that you use specific UUIDs or something?

Post Reply