Windows Creator update causing REPL issues and delay in showing drive

General discussions and questions abound development of code with MicroPython that is not hardware specific.
Target audience: MicroPython Users.
inakto
Posts: 6
Joined: Mon May 15, 2017 7:14 pm

Windows Creator update causing REPL issues and delay in showing drive

Postby inakto » Mon May 15, 2017 7:22 pm

Hi!
I am working on a custom board based on the stm32f405 and a SPI flash. Everything was working great.
After upgrading to the windows 10 creator update a few weeks ago I've encountered some issues, wondering if anyone else is experiencing this. It manifests across multiple computers, and doesn't happen at all on PCs without the creators update or on windows 7.

Issue 1. When plugging in the board, there is no trace of the mass storage device. After 5 minutes or so, repeatably, it shows up.

Issue 2. The REPL locks up randomly and displays no new information, although control-D and control-C commands can still be sent successfully, presumably all inputs work as well. This is tested across multiple terminal emulators. Restarting the terminal emulator seems to fix this. This problem seems to go away after the board has been plugged in for a few hours.

Any ideas or similar experience?

Neil
Posts: 15
Joined: Tue Jul 14, 2015 8:51 pm

Re: Windows Creator update causing REPL issues and delay in showing drive

Postby Neil » Wed May 17, 2017 9:32 am

I am seeing the delay in drive letter issue, but have no issue with REPL.

These problems are common across all three of my pyboards (v1.0, V1.0 LITE and v1.1)

inakto
Posts: 6
Joined: Mon May 15, 2017 7:14 pm

Re: Windows Creator update causing REPL issues and delay in showing drive

Postby inakto » Thu May 18, 2017 8:17 pm

[quote="Neil"]I am seeing the delay in drive letter issue, but have no issue with REPL.

These problems are common across all three of my pyboards (v1.0, V1.0 LITE and v1.1)[/quote]


Thanks for confirming this. It's been driving me a bit crazy. I suspect it is caused by the new windows feature of supporting partitions on USB mass storage drives.

User avatar
kwagyeman
Posts: 4
Joined: Fri Apr 15, 2016 5:16 pm

Re: Windows Creator update causing REPL issues and delay in showing drive

Postby kwagyeman » Wed May 31, 2017 6:30 am

Hi, all OpenMV Cam boards are suffering from this issue too. Not sure what to do about this...

Damien
Site Admin
Posts: 530
Joined: Mon Dec 09, 2013 5:02 pm

Re: Windows Creator update causing REPL issues and delay in showing drive

Postby Damien » Thu Jun 01, 2017 2:35 am

Does anyone have a microbit (or any generic mbed-enabled board) that they could try with Windows Creator? It has a USB MSC and knowing if it worked or not would help work out where the issue lies.

jsbyysheng
Posts: 1
Joined: Thu Jun 01, 2017 12:35 pm

Re: Windows Creator update causing REPL issues and delay in showing drive

Postby jsbyysheng » Thu Jun 01, 2017 12:37 pm

[quote="Damien"]Does anyone have a microbit (or any generic mbed-enabled board) that they could try with Windows Creator? It has a USB MSC and knowing if it worked or not would help work out where the issue lies.[/quote]
I tried MSC in my msp430f6638 launchpad(designed by myself), it works well.

chrismas9
Posts: 31
Joined: Wed Jun 25, 2014 10:07 am

Re: Windows Creator update causing REPL issues and delay in showing drive

Postby chrismas9 » Fri Jun 02, 2017 10:03 am

Hi Damien,

A Freescale KL27 board works fine. So does the embedded ST-LINK on an L476 Discovery board. Both install VCP and MSC correctly.

Problem seems to be only with Micropython. Com port is also unreliable. Sometimes usbser driver fails. I tried changing boot.py to VCP and HID. Now after resetting the filesystem the pyboard randomly appears in device manager as COM5 & MSC or COM13 and HID when unplugged and plugged in again.

I am setting up USBlyser on an Anniversary and Creator systems and will compare and post the results​, probably this weekend.

MAGI
Posts: 1
Joined: Mon Jun 05, 2017 4:54 pm

Re: Windows Creator update causing REPL issues and delay in showing drive

Postby MAGI » Mon Jun 05, 2017 5:06 pm

Same problem with me,I use a custom board by me based on STM32F405.

And the board is still work fine with other computer that didn't install creator update.

chrismas9
Posts: 31
Joined: Wed Jun 25, 2014 10:07 am

Re: Windows Creator update causing REPL issues and delay in showing drive

Postby chrismas9 » Tue Jun 06, 2017 11:59 am

This has been fixed here.
https://github.com/micropython/micropyt ... -306066109

You can either merge Damien's PR or wait until it is released into mainline.

inakto
Posts: 6
Joined: Mon May 15, 2017 7:14 pm

Re: Windows Creator update causing REPL issues and delay in showing drive

Postby inakto » Fri Jun 09, 2017 2:51 am

This is great, I'm glad it's been fixed, thanks.


Return to “General Discussion and Questions”

Who is online

Users browsing this forum: No registered users and 2 guests