firmware install problem

General discussions and questions abound development of code with MicroPython that is not hardware specific.
Target audience: MicroPython Users.
Posts: 40
Joined: Sat Jan 19, 2019 8:01 pm

Re: firmware install problem

Post by nagylzs » Tue Jan 28, 2020 7:50 am

tve wrote:
Mon Jan 27, 2020 5:12 am
Also, I see no "strapping" resistors, e.g. on io12, io15, io2, io5. These could have any value if they're floating and could work on a good day and break on a bad one. Please refer to section 2.4 "Strapping Pins" of the esp32 datasheet. Your hardware design needs some serious updates...
Double checked again. ( ... eet_en.pdf page 16 section 2.4) All of these pins have the "right" internal pull-up and pull-down resistors.

I have also checked the so called "cross bjt" schematic, used on nodemcu. It is used on those boards because they want to be compatible with the arduino IDE. Arduino uses both DTR and RTS for flashing, but this does not work with ESP chips. By using this "cross bjt" schematic with the 1uF cap between GND and reset pins, the ESP chip can also be correctly reseted when DTR + RTS is kept high at the same time. But this is for compatibility with the arduino IDE only. When using esptool, it is not required. You can check in the source code of here: ...

It does the 100msec delay from software code, and it never turns on both lines at the same time.

My conclusion is that my board schematic is just fine. There is something else causing the problem.

Posts: 3
Joined: Wed Dec 25, 2019 5:55 pm

Re: firmware install problem

Post by adomanim » Tue Feb 04, 2020 4:54 pm

Not working here either... Exact same problem. Stuck on 'update' and 'unable to install firmware'. Tried to reboot, tried another cable...

Tutuapp 9apps Showbox

Posts: 40
Joined: Sat Jan 19, 2019 8:01 pm

Re: firmware install problem

Post by nagylzs » Sat Jun 27, 2020 2:25 pm

After 6 months, I decided to give it another try. I have installed my dev environment again and flashed the custom firmware to the same board. It is exactly the same firmware (it was compiled in january), and it is exactly the same hw. board. I wanted to try the boot process with different strapping pin states.

But there was no error. It just works, out of the box! The only thing changed is that I used a different computer to flash the firmware. But it should not affect anything.

This is magical!

Post Reply