rshell no micropython boards connected

General discussions and questions abound development of code with MicroPython that is not hardware specific.
Target audience: MicroPython Users.
Post Reply
User avatar
philwilkinson40
Posts: 61
Joined: Tue Nov 14, 2017 3:11 am
Location: Perth, Australia

rshell no micropython boards connected

Post by philwilkinson40 » Wed Nov 25, 2020 11:48 pm

I have been using rshell for years on Ubuntu and it is a great tool.

However, I have recently attempted to use rshell it on a Raspberry Pi connected by a USB serial to an ESP32.
The raspberry pi uses the latest version of Raspberry Pi OS Lite
I have flashed the latest stable version of ESP32 (1.13) firmware on the connected board
I have enabled the serial port permissions

rshell fails to find any connected boards.
picocom connects to the board without any problem using:

Code: Select all

picocom /dev/ttyUSB0 -b115200
There appears to be no post on the forum similar to this issue, so perhaps it is something very obvious I am missing!
Any ideas?

User avatar
dhylands
Posts: 3586
Joined: Mon Jan 06, 2014 6:08 pm
Location: Peachland, BC, Canada
Contact:

Re: rshell no micropython boards connected

Post by dhylands » Thu Nov 26, 2020 2:12 pm

I'm pretty sure that rshell will only automatcally detect the pybord. For other devices you need to specify the port using the -p command:

Code: Select all

 rshell -p /dev/ttyUSB0
or use the connect command from within rshell.

User avatar
philwilkinson40
Posts: 61
Joined: Tue Nov 14, 2017 3:11 am
Location: Perth, Australia

Re: rshell no micropython boards connected

Post by philwilkinson40 » Thu Nov 26, 2020 11:53 pm

Damn!
I must have got so used to using the pyboard I forgot how to connect a ESP!
Apologies

Post Reply