Problem Installing Required Dependencies

General discussions and questions abound development of code with MicroPython that is not hardware specific.
Target audience: MicroPython Users.
Post Reply
ErranS
Posts: 2
Joined: Fri Feb 19, 2021 12:19 pm

Problem Installing Required Dependencies

Post by ErranS » Fri Feb 19, 2021 1:43 pm

I have been working through the Getting Started section under MicroPython Internals and everything was going fine until I got to the step of installing the ARM cross-compiler for the STM32.

I am running a new installation of Linux Mint 20.1 and here is what happened:

es@es-Latitude-E6520:~/Projects/micropython$ sudo apt-get install arm-none-eabi-gcc arm-none-eabi-binutils arm-none-eabi-newlib
[sudo] password for es:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package arm-none-eabi-gcc
E: Unable to locate package arm-none-eabi-binutils
E: Unable to locate package arm-none-eabi-newlib

I have searched the forum but was unable to locate anything like this.
Any thoughts or advise would be greatly appreciated.

Thanks to all.

Christian Walther
Posts: 129
Joined: Fri Aug 19, 2016 11:55 am

Re: Problem Installing Required Dependencies

Post by Christian Walther » Fri Feb 19, 2021 10:07 pm

I think you now need to get the toolchain from https://developer.arm.com/tools-and-sof ... /downloads , but I’m not sure (have never built for STM32 myself), and I don’t know which version is best.

User avatar
jimmo
Posts: 2244
Joined: Tue Aug 08, 2017 1:57 am
Location: Sydney, Australia
Contact:

Re: Problem Installing Required Dependencies

Post by jimmo » Mon Feb 22, 2021 3:51 am

ErranS wrote:
Fri Feb 19, 2021 1:43 pm
I have searched the forum but was unable to locate anything like this.
I'm guessing the package is called something different on Mint?

Have you tried https://community.linuxmint.com/softwar ... -none-eabi

Post Reply