Page 1 of 1

deploy-stlink error

Posted: Sun Jan 27, 2019 10:50 am
by forester3
Hi,

In accordance with v1.10 release, I am developing f7-disco micropython custom firmware.
However, an error has occurred at deploy-stlink. The error messages are as follows:
st-flash 1.4.0-20-gaf4d2eb
2019-01-27T19:27:55 WARN usb.c: Couldn't find any ST-Link/V2 devices
Makefile:514: recipe for target 'deploy-stlink' failed
make: *** [deploy-stlink] Error 255

Last year I was developing with Mint 18 (ubuntu 16.04 LTS), but this year I got Mint 19 (ubuntu 18.04 LTS).
How to reinstall st-flash?

Re: deploy-stlink error

Posted: Sun Jan 27, 2019 12:34 pm
by forester3
This time I reinstalled udev rule only.
Then somehow the st-flash worked.
But can ubuntu18.04 build st-flash binary?

Re: deploy-stlink error

Posted: Mon Jan 28, 2019 11:48 am
by forester3
Sorry, this is a self-replying.

I tried to build without cmake and I was not able to build again.

There was an example of a build that does not use git. (It is a only in Japanese.)
http://mickey-happygolucky.hatenablog.c ... /27/220613

I would normally like to use the "make" command.